Good Sam Club Open Roads Forum: Onan generator error code 32 - starting problem
Open Roads Forum Already a member? Login here.   If not, Register Today!  |  Help

Newest  |  Active  |  Popular  |  RVing FAQ Forum Rules  |  Forum Help and Support  |  Contact

Search:   Advanced Search

Search only in Tech Issues

Open Roads Forum  >  Tech Issues

 > Onan generator error code 32 - starting problem

This Topic Is Closed  |  Print Topic  |  Post New Topic  | 
gomingus

Saline, MI

New Member

Joined: 11/15/2004

View Profile



Good Sam RV Club Member


Posted: 04/04/10 06:46pm Link  |  Print  |  Notify Moderator

I have a Onan 5500 gold generator that will start briefly but then shut off. The error code is 32 which states that it is either low on oil or the battery doesn't have enough cranking power to start it for more than 2 seconds. It has plenty of oil.

Here is my question for anyone that has had a similar problem. ---

(1) Does the generator's starter crank from the chassy battery then charge the interior coach batteries or is it only connected to the interior coach batteries for all service. The reason I ask is that is I just tested the chassy battery and it looks very weak even after putting a charger on it, but it still starts the motor home. A test of the battery acid water confirmed the battery has little or no charge. (2) My thoughts are to change the chassy battery and see if that will fix the starting of the generator.

I have also heard other people that the code is not correct and that it is a problem with the carberator. But it seems like a safety system is preventing the generator from running and because it will start briefly then shut down.

Any suggestions will be helpful.

Jim


2005 Winnebago Adventurer 33v
Workhorse W22 Chassis
Honda Pilot Tow

lizbard

Nacogdoches, TX

Senior Member

Joined: 05/24/2009

View Profile





Offline
Posted: 04/04/10 09:50pm Link  |  Print  |  Notify Moderator

I had that code last year and was taking my RV to the shop for other repairs. They had me drive it to a certified Onan dealer for repairs. I do not remember what the problem was, but it had to do with something being repaired. I had new batteries and it was serviced when I bought it. It cost less than $500 and took a couple of days to a week. I have the paperwork in the RV but cannot get to it right now.

gomingus

Saline, MI

New Member

Joined: 11/15/2004

View Profile



Good Sam RV Club Member


Posted: 04/08/10 08:50pm Link  |  Print  |  Notify Moderator

lizbard wrote:

I had that code last year and was taking my RV to the shop for other repairs. They had me drive it to a certified Onan dealer for repairs. I do not remember what the problem was, but it had to do with something being repaired. I had new batteries and it was serviced when I bought it. It cost less than $500 and took a couple of days to a week. I have the paperwork in the RV but cannot get to it right now.


Any additional information that you can pass on would be great. I haven't taken it in yet, but thought it might be something simple as it was working fine a few months ago when I started it up.

gomingus

Saline, MI

New Member

Joined: 11/15/2004

View Profile



Good Sam RV Club Member


Posted: 04/08/10 08:52pm Link  |  Print  |  Notify Moderator

Yesterday I installed two new coach batteries and it still has the same error code.

gomingus

Saline, MI

New Member

Joined: 11/15/2004

View Profile



Good Sam RV Club Member


Posted: 04/17/10 12:31pm Link  |  Print  |  Notify Moderator

Had someone tell me to disconnect the control panel that contains the start button and plug it back in. He says it works like a computer and sometimes needs to be reset. Any one with other ideas

Tarheel 2

North Carolina

Senior Member

Joined: 02/27/2005

View Profile



Good Sam RV Club Member


Posted: 04/17/10 06:11pm Link  |  Print  |  Notify Moderator

Have you had it serviced recently? I had the same issue three or four years ago when I had mine serviced at an FMCA rally by Cummins/Onan techs in Florida. The were very emphatic that my problem was not the oil change, but something else. I kept insisting that they install another oil filter and instead, they replaced a couple of internal components that did not correct the problem. After spending all week at their facility I raised my voice a few octives and told them they were going to replace the oil filter that they had just installed. Guess what, they did it to pacify me and the generator ran great for the next four years until I recently traded it.


Tarheel

This Topic Is Closed  |  Print Topic  |  Post New Topic  | 

Open Roads Forum  >  Tech Issues

 > Onan generator error code 32 - starting problem
Search:   Advanced Search

Search only in Tech Issues


New posts No new posts
Closed, new posts Closed, no new posts
Moved, new posts Moved, no new posts

Adjust text size:

© 2014 Good Sam Club | Terms & Conditions | PRIVACY POLICY | YOUR PRIVACY RIGHTS