Good Sam Club Open Roads Forum: Search
Open Roads Forum Already a member? Login here.   If not, Register Today!  |  Help

Newest  |  Active  |  Popular  |  RVing FAQ Forum Rules  |  Forum Posting Help and Support  |  Contact  



Open Roads Forum  >  Search the Forums

 > Your search for posts made by 'GGeorge' found 7 matches.

Sort by:    Search within results:
  Subject Author Date Posted Forum
RE: Kwikee step issue

No noise or click. The steps operate, but they operate in reverse. When the door is closed the steps are open, when the door is open the steps are in except when I use the switch. When I turn on the key the steps open.
GGeorge 10/11/18 04:05pm Class A Motorhomes
Kwikee step issue

I am attempting to replace my Kwikee steps. The old steps broke (again) and were very rusty, so I purchased new Kwikee steps. The new steps fit perfect. I have read the operators manual 6 times but I can not get them to extend when I open the door not retract when I close the door. I did no new wiring. The magnet on the door is the same. The plug wires match the old steps but the run backwards. There is a switch I can flip to keep them open when parked which I have turned on and off trying the steps in each position. Any ideas? Thanks in advance GGeorge
GGeorge 10/08/18 11:28am Class A Motorhomes
Black/Gray tank maintenance

Has anyone ever tried Rid-X in your holding tank to help clean the sensors and tanks? Seems like a much cheaper way to get rid of the grime in the tank. Thanks for your advise.
GGeorge 09/20/18 06:10pm Class A Motorhomes
RE: help with electrical please

after studying the circuit panel and realizing that one 50amp side controlled what worked and one 50amp side controlled what did not work I went back to the nifty surge protector which told me line 1 was drawing 30amps and line 2 was drawing 0 amps. I am in the process of replacing the plug. Thanks to all for your speed and helpful responses. GGeorge
GGeorge 08/09/18 07:14pm Class A Motorhomes
RE: help with electrical please

my $450 surge protector says both lines are showing at least 118 thru 121.
GGeorge 08/09/18 05:50pm Class A Motorhomes
RE: help with electrical please

any thoughts on where it will be. I have checked all recepticles I know of and I found only 1 in the half bath
GGeorge 08/09/18 05:34pm Class A Motorhomes
help with electrical please

I have a 2014 Coachmen Encounter, I am sitting in Tacoma WA @ JBLM Holiday Park. I am plugged into a 50Amp shorepower. My front A/c, washer/dryer, fireplace, water heater, front tv and 4 power recepticles are working. My rear a/c, microwave, and refrig are not working along with 5 outlets. both bathrooms are working with electricity. I have checked for fuse blowout and all are ok. I have turned all fuses on and off. I have done the same with the "main". Currently my generator is in the shop and not connected. I have checked the GFI and it has been reset but was not triggered before the reset. ANY IDEAS???? G George
GGeorge 08/09/18 05:26pm Class A Motorhomes
Sort by:    Search within results:


New posts No new posts
Closed, new posts Closed, no new posts
Moved, new posts Moved, no new posts

Adjust text size:

© 2019 CWI, Inc. © 2019 Good Sam Enterprises, LLC. All Rights Reserved. | Terms of Use | PRIVACY POLICY | YOUR PRIVACY RIGHTS