Good Sam Club Open Roads Forum: Search
Open Roads Forum Already a member? Login here.   If not, Register Today!  |  Help

Newest  |  Active  |  Popular  |  RVing FAQ Forum Rules  |  Forum Posting Help and Support  |  Contact  



Open Roads Forum  >  Search the Forums

 > Your search for posts made by 'GTMADNS' found 6 matches.

Sort by:    Search within results:
  Subject Author Date Posted Forum
RE: Dometic roof top ac unit

Well I cleaned the condenser last weekend and used it this past weekend and now the motor is seizing up. I can replace motor pretty easy but don’t know if that was my problem all along or if I still have a Freon issue
GTMADNS 08/12/19 11:32am Class A Motorhomes
Dometic roof top ac unit

Can the roof tops ac unit by Dometic be recharged ?we have a 2014 sport coach. Back ac is ice cold front unit at same temp is cool but not cold. Thanks in advance
GTMADNS 07/14/19 06:59am Class A Motorhomes
RE: Water pressure issue

Figured it out. There are 6 Valves in compartment 4 are drains and 2 I have no idea but turning one it had normal psi. Thanks guys
GTMADNS 06/18/19 06:43pm Class A Motorhomes
RE: Water pressure issue

I changed the main water filter in the water fill compartment. It is definitely holding psi. As soon as I twisted the filter off it shot pressurized water out. No other filter i see under any of the sinks. This water issue is in every sink and the shower. I have a spare water pump from last rv it’s the same pump I was thinking of changing that tonight to see if it’s the same. I am not hooked up to city water and running the pump at the same Time I did fill the water tank full yesterday as well so I know that’s at the top of the tank. I’m calling coachman. There are a few valves in the water compartment that I’m not sure what they are for yet. I figured out the drains on the system.
GTMADNS 06/18/19 07:18am Class A Motorhomes
RE: Water pressure issue

Would there not be a water leak on the suction side if there was a crack ?
GTMADNS 06/18/19 03:58am Class A Motorhomes
Water pressure issue

Purchased my second class a pusher over the weekend. Have had another class a for 8 years so not new to rv’ing. Question for you all. This new one the water when going through the water seems to constantly have air in the line after I run the faucet or shower water for about 20 seconds or more. Water starts out strong then starts to sputter. I changed the water filter today and no change. To me seems like a lot of air still in system. I hooked up city water and ran the air out of system that way but as soon as I turn it off and turn water pump back on does same thing. Any thoughts other than there is more air in the system. Rv was in dealer inventory for 2 months before I purchased. Rv is a 2014 coachmen cross country sport Coach.
GTMADNS 06/17/19 09:07pm Class A Motorhomes
Sort by:    Search within results:


New posts No new posts
Closed, new posts Closed, no new posts
Moved, new posts Moved, no new posts

Adjust text size:




© 2020 CWI, Inc. © 2020 Good Sam Enterprises, LLC. All Rights Reserved.