Good Sam Club Open Roads Forum: Search
Open Roads Forum Already a member? Login here.   If not, Register Today!  |  Help

Newest  |  Active  |  Popular  |  RVing FAQ Forum Rules  |  Forum Posting Help and Support  |  Contact  



Open Roads Forum  >  Search the Forums

 > Your search for posts made by 'Jake2008' found 1 matches.

Sort by:    Search within results:
  Subject Author Date Posted Forum
Bedroom Slide Issue

I am having a new issue with my bedroom slide. I pulled into a campsite on Tuesday. In the process of setting up, I began to extend the bedroom slide of my Newmar Cypress 5th wheel. As it was opening, it was moving a bit sluggish. The motor sounded strong. I thought the slide was not all the way out, so I pushed and held the bottom to retract the slide. The motor turned on but the slide would not move. I was able to determine, that with the switch depressed in either direction, that the motor was on and was attempting to turn the shaft. (Its an electrical Rack and Pinion system). However, the shaft would turn slightly and then skip. The slide would not move. At this point, the slid is out most of the way. But I am not able to get it fully out or back in. Comments and suggestions to repair would be most appreciated!!!
Jake2008 06/05/21 04:01am Fifth-Wheels
Sort by:    Search within results:


New posts No new posts
Closed, new posts Closed, no new posts
Moved, new posts Moved, no new posts

Adjust text size:




© 2022 CWI, Inc. © 2022 Good Sam Enterprises, LLC. All Rights Reserved.