Good Sam Club Open Roads Forum: Search
Open Roads Forum Already a member? Login here.   If not, Register Today!  |  Help

Newest  |  Active  |  Popular  |  RVing FAQ Forum Rules  |  Forum Posting Help and Support  |  Contact  



Open Roads Forum  >  Search the Forums

 > Your search for posts made by 'LRBill' found 4 matches.

Sort by:    Search within results:
  Subject Author Date Posted Forum
RE: We have a toilet issue......

Thanks for the link. Parts are ordered and will takce care of it this week. Thanks all for the help!
LRBill 09/20/20 02:13pm Tech Issues
RE: We have a toilet issue......

Well, the olive oil did not do the trick. Must have a small crack in the seal. The toilet is a Thetford Aqua-Magic II . Ceramic bowl. I'll have to look into a new seal I'm guessing.... Thanks for your thoughts!! Bill
LRBill 09/20/20 11:44am Tech Issues
RE: We have a toilet issue......

Ahhhh, never thought of those ideas. Thanks for the help!
LRBill 09/18/20 07:14pm Tech Issues
We have a toilet issue......

We keep a bit of water in the toilet at all times to keep the seal wet but during this last drought spell it dried up and now doesn't hold water in the bowl. I have washed the seal thoroughly and put a rag down on it and kept it wet for a few hours but no dice. What do I have to do to get it to seal again? Does the seal need to be replaced? That looks like it would be a real pain... Any intel on this would really be appreciated! Bill
LRBill 09/18/20 05:35pm Tech Issues
Sort by:    Search within results:


New posts No new posts
Closed, new posts Closed, no new posts
Moved, new posts Moved, no new posts

Adjust text size:




© 2020 CWI, Inc. © 2020 Good Sam Enterprises, LLC. All Rights Reserved.