Good Sam Club Open Roads Forum: Search
Open Roads Forum Already a member? Login here.   If not, Register Today!  |  Help

Newest  |  Active  |  Popular  |  RVing FAQ Forum Rules  |  Forum Posting Help and Support  |  Contact  



Open Roads Forum  >  Search the Forums

 > Your search for posts made by 'ShotgunWriter' found 4 matches.

Sort by:    Search within results:
  Subject Author Date Posted Forum
RE: House Power Problem

WE HAVE LIGHT!!! Hubby did a lot of homework and figured out that it's a failure of the solenoid for the battery cutoff. We had checked the switch before, but this was controlling the switch and everything else DC. So glad! Thanks for your input!
ShotgunWriter 05/17/19 05:43pm Class A Motorhomes
RE: House Power Problem

Malexander , do you think it could be the inverter, even though it appears to be working properly? (Charging the batteries, clicking on and off with power source change, breaker switches working?) I'm really hoping to not buy an inverter right now. My savings account has taken some pretty big hits this month.
ShotgunWriter 05/17/19 06:43am Class A Motorhomes
RE: House Power Problem

Hello and thanks for your help so far. To give more info... We do have a large, permanent inverter near the battery compartment, and a smaller, portable one that we plug into the dash receptacle so we have 2 outlets for devices that don't have cigarette plugs. Husband bought 4 new batteries today. No change in status. We had flickering lights when we used the water pump this weekend while boondocking. When we switch from shore power to generator, the large inverter changes from a humming noise to a single click and then no noise. Breaker switches located on large inverter turn various things on and off. Two switches that each control half of RV. We have checked every breaker, fuse and switch we can find. Husband is continuing to go through every nook and cranny looking for one of the above. The following are items that are working or not. There is no change with the generator vs. Shore power: Cigarette lighter receptacle in dash NOT House lights NOT Both TVs WORKING Microwave WORKING Water heater NOT Water pump NOT Fridge (residential, only uses electric) WORKING A/C no power to controls/thermostat to turn them on Power outlets WORKING Washer/dryer NOT Cargo lights NOT Thanks again. Keep the ideas coming!
ShotgunWriter 05/16/19 07:58pm Class A Motorhomes
House Power Problem

HELP! We need help with a power/electrical issue in our 2004 Holiday Rambler Ambassador. Went on a little trip over the weekend. We always travel with a dash camera, that is powered by a portable inverter that plugs into our cigarette lighter in the dash. We also had one cell phone plugged into the inverter. Generator not turned on. After a few hours of driving, the inverter started beeping and had a "low battery" indicator. We turned it off, as we were almost home. As we arrived home we discovered that we have power to outlets, microwave, and TV, but not lights or washing machine. This happened once before, but our house batteries were just low. Charged them up, and everything worked just fine. This time, however, after charging, we still have no power. Batteries are reading full according to voltage meter. All fuses and breaker switches have been checked. Husband says large inverter is good, because he hears it come on, click on as it's supposed to, and it charges the batteries. We have checked the water level in the batteries and took the batteries themselves to Auto Zone to get checked. All checked out at 100% charge and around 6.5V. What are we missing? Why do we have no power? And what do we need to do differently in the future to avoid this problem? Thanks in advance!
ShotgunWriter 05/15/19 07:55pm Class A Motorhomes
Sort by:    Search within results:


New posts No new posts
Closed, new posts Closed, no new posts
Moved, new posts Moved, no new posts

Adjust text size:




© 2020 CWI, Inc. © 2020 Good Sam Enterprises, LLC. All Rights Reserved.