Good Sam Club Open Roads Forum: Search
Open Roads Forum Already a member? Login here.   If not, Register Today!  |  Help

Newest  |  Active  |  Popular  |  RVing FAQ Forum Rules  |  Forum Posting Help and Support  |  Contact  



Open Roads Forum  >  Search the Forums

 > Your search for posts made by 'Steve92004' found 4 matches.

Sort by:    Search within results:
  Subject Author Date Posted Forum
RE: Onan 4000 Microliite Carb Spewing Gas from Air Filter

Still starting great Do you guys drain the float bowl after use so it doesn't get gummed up in there? That's the reason I put the fuel shut off valve on there so I could run it empty like I do on my dirt bikes and things that don't get used daily> But when I saw how much came out when I removed the float bowl I'm thinking there's still enough in there to gum up the altitude needle at the bottom
Steve92004 11/08/18 05:57pm Tech Issues
RE: Onan 4000 Microliite Carb Spewing Gas from Air Filter

Thanks guys I pulled the float bowl, the float was fine and not full of gas I didn't like how far up the float traveled so I swapped it with my original Onan float and needle. Now it shuts off the fuel to the carb when the float is about level I started it a couple times and didn't notice any excess fuel spraying out So I got it running on a full load right now and going to let it run 30 minutes Crossing my fingers
Steve92004 11/08/18 05:35pm Tech Issues
RE: Onan 4000 Microliite Carb Spewing Gas from Air Filter

Sounds like a carburetor float with a leak. The float fills with gas and sinks, allowing the float valve to stay open resulting in the carburetor bowl overflowing. That makes sense right there
Steve92004 11/07/18 07:36pm Tech Issues
Onan 4000 Microliite Carb Spewing Gas from Air Filter

Hi everybody I had a surging issue with my Onan 4000 Microlite (800 hours) I would clean the carb and sometimes it would fix it and sometimes not So I bought a new Amazon Carb, Fuel Pump and Fuel Filter I put it all in and the generator started right up and ran perfect. Then I turned it off after a bit to see if it would restart and it wouldn't. I was troubleshooting and removed the air filter and gas poured out of it and when I cranked it over gas was spraying out of the filter side of the carb I had put in a fuel cut off valve during the install so I shut off the fuel and tried again and the genny started right up I opened up the fuel valve and it kept running perfect but when I shut it off and tried to restart, gas was spraying out of the intake again and it wouldn't start unless I shutoff the fuel valve. Do you think the fuel pump is pumping too much fuel or do you think the carb is defective? Thanks!
Steve92004 11/07/18 07:24pm Tech Issues
Sort by:    Search within results:


New posts No new posts
Closed, new posts Closed, no new posts
Moved, new posts Moved, no new posts

Adjust text size:

© 2019 CWI, Inc. © 2019 Good Sam Enterprises, LLC. All Rights Reserved. | Terms of Use | PRIVACY POLICY | YOUR PRIVACY RIGHTS