Good Sam Club Open Roads Forum: Search
Open Roads Forum Already a member? Login here.   If not, Register Today!  |  Help

Newest  |  Active  |  Popular  |  RVing FAQ Forum Rules  |  Forum Posting Help and Support  |  Contact  



Open Roads Forum  >  Search the Forums

 > Your search for posts made by 'brianseay1' found 15 matches.

Sort by:    Search within results:
  Subject Author Date Posted Forum
RE: 2005 Discovery generator problem

are you holding the switch down long enough for the glow plug to heat? mine usually take at least a minute and a half before the engine starts turning over I'm doing it the same way I do in my coach. In mine, as soon as I hit the button I get the green indicator light flashing and you can hear it going thru the steps to start. On this one, you can hit the button and nothing is happening. You go out and hit the switch on the generator itself, the indicator light comes on and starts rapid flashing the code.
brianseay1 09/10/22 07:46pm Class A Motorhomes
RE: 2005 Discovery generator problem

Did I miss brand and model of generator? sorry about that, its a Onan superquite7500 diesel.
brianseay1 09/10/22 07:43pm Class A Motorhomes
2005 Discovery generator problem

A buddy of mine is looking at buying a 2005 Fleetwood Discovery J model. It has 27,500 miles on it and has been garage kept. Coach looks great. The problem is we can't get the generator to start. It had bad batteries, and new ones have been installed. But it will not turn over. The dash switch does not light up when you push it to start. The switch on the generator will light up and throw a code. at first it was 3 rapid flashes followed by a hesitation and then 3 more rapid flashes. Once i get it in the mode to check it will flash code 4-6. The batteries are fully charged and wired correctly. can't figure out why it will not start and why I don't have an indicator light on dash switch but I do have it on generator switch. The owner said he has never had an issue with it starting until the batteries went bad. My buddy knows the owner real well, so we know he is on the level with us. We had found some of the electrical things were not working, but that was due to a tripped GFCI circuit. Any help is greatly appreciated.
brianseay1 09/10/22 04:30pm Class A Motorhomes
RE: Engine air filter

That’s pretty close to what mine looks like. I can’t find a number on it, I haven’t taken it off yet. I was going to order me a new one online and get it before I took it all apart. Thx for the help.
brianseay1 08/08/22 02:00pm Class A Motorhomes
Engine air filter

Would anyone happen to have the part number for the engine air filter fir a 2007 Coachmen Cross Country 389DS motorhome ?
brianseay1 08/08/22 01:02pm Class A Motorhomes
RE: 05 Fleetwood Discovery chassis ????

That’s what I’m thinking it could be, just wanted to get some feedback from others that may know more about it.
brianseay1 08/04/22 07:27pm Class A Motorhomes
RE: 05 Fleetwood Discovery chassis ????

Or could it just ne the way the body shifts on the air ride bags when they deflate ? Going to check the ride height valve/rods to see what they measure. The coach only has 19,000 miles on it. The man that owns it is selling it for his mom. His parents bought it new and his dad passed away and it has been garaged since then. It has been sitting for quite some time.
brianseay1 08/04/22 12:47pm Class A Motorhomes
RE: 05 Fleetwood Discovery chassis ????

Would that make it sit further to one side than the other ? its kinda like the axle is off center. I know its not, but that's what it makes me think the way sits.
brianseay1 08/04/22 12:44pm Class A Motorhomes
05 Fleetwood Discovery chassis ????

Friend of mine is looking at a 2005 Fleetwood Discovery. Rig looks great, really been taken care of. But I noticed when the coach is sitting on the frame with air ride bags deflated you can barely get your fingers between the left rear tires and the body. The right side has plenty of clearance. I know on my coach I do not have this problem. It just seems odd that it would sit like this. Is this normal on the Discovery ? it is a one owner coach, and it has never been wrecked or damaged. But this would worry me if it were mine. Told my buddy let me check around on here and see if anyone else has ever came across something like this. Any info is greatly appreciated.
brianseay1 08/04/22 12:24pm Class A Motorhomes
awning issues

I have a 2007 Coachmen Cross Country 389DS. I am trying to find the model number on my awning. It is an A&E two step awning (manual). the only number I have found is 3307846.125 and that is on the arm. I have pulled out all of my manuals for the coach and can't find the number. It measures 16'9" inside of arm to inside of arm. The awning will free fall when lowering and it will not roll back up without doing it by hand. If anyone can help me out with any info it would greatly be appreciated.
brianseay1 07/12/22 07:55pm Class A Motorhomes
RE: Air brake issues

Just spoke with a guy from Freightliner in Gaffney SC. He said it could be in my wiring harness if I had the white wires (which I do). He said there had been problems with the wiring harness causing faulty readings. Told me I needed to upgrade to the Pollic Jumper Harness (black wires). said the clips were tighter making for a better connection. If that didn't fix it, I could have a gauge going bad.
brianseay1 04/13/22 10:08am Class A Motorhomes
RE: Air brake issues

I am on the Freightliner chassis.
brianseay1 04/13/22 08:12am Class A Motorhomes
Air brake issues

On our return trip home today I got he low air pressure warning light?buzzer on the dash and the #1 air gauge went crazy for about 3-5 seconds and then everything was fine. Couple miles down the road it did it again, then few more miles it cam on and stayed for a couple of minutes and the gauge was reading zero. Then it shot back up to regular pressure and light/buzzer went off. Never had any issues with braking during any of this. I stopped at the first rest area I came to while the light was on, got out to inspect to see if I could find any air leaks. Did not hear anything at all, no smell of heated/burning brakes. I turned the engine off and sat for a few minutes to see if I could get a call in to Freightliner, but had no luck. I was 87 miles from home. So I started back up and everything was fine. the remaining drive home it went off twice for about 5 seconds each time. The batteries are fine, so I'm not really sure where to start looking. Anyone have any ideas on what to check first ? I'm thinking a pressure sensor is going bad. Don't think it is an actual air leak because the air pressure goes back to normal within seconds of it acting up. Any help is greatly appreciated.
brianseay1 04/12/22 09:49pm Class A Motorhomes
RE: 2007 Cross Country headlights

Thanks for the input, I found the headlight info and got the correct bulb i needed.
brianseay1 04/12/22 09:38pm Class A Motorhomes
2007 Cross Country headlights

Im having a hard time finding replacement headlights for my 2007 Coachmen Cross Country 389DS motorhome. I have googled them several times and coming up empty handed. Has anyone replaced theirs? does anyone have a part # for them? or a place where I can purchase them ? Any help is greatly appreciated.
brianseay1 04/04/22 08:31pm Class A Motorhomes
Sort by:    Search within results:


New posts No new posts
Closed, new posts Closed, no new posts
Moved, new posts Moved, no new posts

Adjust text size:




© 2022 CWI, Inc. © 2022 Good Sam Enterprises, LLC. All Rights Reserved.