Good Sam Club Open Roads Forum: Search
Open Roads Forum Already a member? Login here.   If not, Register Today!  |  Help

Newest  |  Active  |  Popular  |  RVing FAQ Forum Rules  |  Forum Posting Help and Support  |  Contact  



Open Roads Forum  >  Search the Forums

 > Your search for posts made by 'egrove' found 5 matches.

Sort by:    Search within results:
  Subject Author Date Posted Forum
RE: Signing a power of attorney for bank when selling your RV

I recently sold an RV and the buyer used this company to finance. They asked for same from me. I was a little hesitant at first but did a little research and went ahead with it. Had no issues, and process went smooth for me. Wasn't so smooth for the buyer, but that was for unrelated issues.
egrove 11/11/19 10:54am General RVing Issues
RE: Suspension upgrade disappointment.

Are you saying it used to drive better and has now gotten worse? If so, I would look at items that have worn out, instead of adding new parts such as sway bars and track bars. What is the condition of the shocks and other suspension components as Don mentioned?
egrove 10/04/19 09:29am Class C Motorhomes
RE: Some poor fellas waste tank broke!

Years ago I was driving on route 84 through Columbia River Gorge and came across a fresh water tank laying in the middle of the passing lane. Assuming it was full. Hope no one hit it! They probably didn't even know they lost it until they got to their destination.
egrove 08/30/19 08:06am General RVing Issues
RE: Dometic AC potential issues

Most likely have a refrigerant leak. Mine had same behavior (freezing up, not much cooling between intake and output). Had to replace whole unit. Some people can find leak and fix and refill, but this isn't recommended and considered a short term fix.
egrove 07/17/19 11:19am Tech Issues
RE: Think you can follow instructions?

From factory my Coleman Mach had it located on the lower half of the coil, as others have stated. My unit would still freeze up. Upon examination I noticed the top half of the coil had ice build up, so I moved the sensor to the upper half and no longer have issues.
egrove 02/13/19 11:24am Tech Issues
Sort by:    Search within results:


New posts No new posts
Closed, new posts Closed, no new posts
Moved, new posts Moved, no new posts

Adjust text size:




© 2020 CWI, Inc. © 2020 Good Sam Enterprises, LLC. All Rights Reserved.