Good Sam Club Open Roads Forum: Tech Issues: Lost power to 3 outlets
Open Roads Forum Already a member? Login here.   If not, Register Today!  |  Help

Newest  |  Active  |  Popular  |  RVing FAQ Forum Rules  |  Forum Help and Support  |  Contact  

Search:   Advanced Search

Search only in Tech Issues

Open Roads Forum  >  Tech Issues

 > Lost power to 3 outlets

Reply to Topic  |  Subscribe  |  Print Topic  |  Post New Topic  | 
Page of 2  
Next
carjockie

Pittsburgh, Pa

New Member

Joined: 03/20/2004

View Profile



Good Sam RV Club Member


Posted: 11/10/17 09:47am Link  |  Quote  |  Print  |  Notify Moderator

i lost power to 3 electrical outlet, check the ground fault but that didn't power the outlets. Check the circuit breakers and they are on on, any other suggestion would be appreciated. Right now I have a double male supplying power to the three outlets. Is it possible I've have a broken wire?



❚ Did you miss the FTS "Announcement : READ BEFORE POSTING HERE"?
    Forum Technical Support (FTS) is reserved for questions related to the use of the Open Roads Forum sites,
    member profile and photo testing, and for reporting account issues. Please avoid using FTS for RV related
    questions. Instead, select the Sub-Forum which corresponds to the subject of your topic.

    Thank-you!


    Moved from FORUM TECHNICAL SUPPORT



* This post was edited 11/10/17 11:40am by an administrator/moderator *

donn0128

Pronounced Ore-gun

Senior Member

Joined: 04/21/2005

View Profile


Offline
Posted: 11/10/17 10:14am Link  |  Quote  |  Print  |  Notify Moderator

RV manufacturers use the absolute cheapest push on wire outlets. They also daisy chain the wiring. So to fix you need to go to each outlet, remove it from the wall and look. My guess you will find a wire off.


Don,Lorri,and Charlie Bear 2016
The Other Dallas


newman fulltimer

louisiana

Senior Member

Joined: 05/19/2012

View Profile


Online
Posted: 11/10/17 10:14am Link  |  Quote  |  Print  |  Notify Moderator

bad plug or a bad wire connection under or in the slide depends on how they connected the wires

Dick_B

Palos Heights, IL USA

Senior Member

Joined: 07/10/2002

View Profile



Good Sam RV Club Member

Offline
Posted: 11/10/17 10:50am Link  |  Quote  |  Print  |  Notify Moderator

Any chance there is a second GFCI?


Dick_B
2003 SunnyBrook 27FKS
2011 3/4 T Chevrolet Suburban
Equal-i-zer Hitch
One wife, two electric bikes (both Currie Tech Path+ models)

Fred/Sheri

Stillwater, Ok, USA

New Member

Joined: 04/11/2001

View Profile



Good Sam RV Club Member

Offline
Posted: 11/10/17 11:02am Link  |  Quote  |  Print  |  Notify Moderator

It could be the outlets on inverred power, so isolation switch or battery

newman fulltimer

louisiana

Senior Member

Joined: 05/19/2012

View Profile


Online
Posted: 11/10/17 11:24am Link  |  Quote  |  Print  |  Notify Moderator

if in a unit with a inverter go flip the breaker back on thats on the inverter itself

time2roll

Southern California

Senior Member

Joined: 03/21/2005

View Profile



Good Sam RV Club Member


Posted: 11/10/17 11:51am Link  |  Quote  |  Print  |  Notify Moderator

Cut the deadman cord in half and throw it away.


2001 F150 SuperCrew
2006 Keystone Springdale 249FWBHLS
675w Solar pictures back up

downtheroad

Pacific Northwest

Senior Member

Joined: 02/18/2003

View Profile



Posted: 11/10/17 12:08pm Link  |  Quote  |  Print  |  Notify Moderator

Had that happen to me also...no power to a couple of outlets...
Discovered that the wires had been severed when they got tangled and then pinched by the slide mechanism.

Spliced the wires back together....then some electrical tape and shrink tubing.


"If we couldn't laugh we would all go insane."

Arctic Fox 25Y
GMC Duramax LBZ
Blue Ox SwayPro

Joe Way

Quincy CA

Full Member

Joined: 07/21/2002

View Profile



Good Sam RV Club Member

Offline
Posted: 11/10/17 01:58pm Link  |  Quote  |  Print  |  Notify Moderator

When this happened to my BIL's trailer it was a tripped GFCI for the refrigerator. Went to the outside access hatch and reset the GFCI.

ScottG

Bothell Wa.

Senior Member

Joined: 02/25/2005

View Profile


Offline
Posted: 11/10/17 02:03pm Link  |  Quote  |  Print  |  Notify Moderator

time2roll wrote:

Cut the deadman cord in half and throw it away.



X2!
This is not the way to do things.


Scott, Grace and Wesly
2003 Dodge 3500 4x4, 6 speed Cummins (lightly bombed),
2018 Silver Fox 32A - many mods to come!
H0NDA eu2000i

Reply to Topic  |  Subscribe  |  Print Topic  |  Post New Topic  | 
Page of 2  
Next

Open Roads Forum  >  Tech Issues

 > Lost power to 3 outlets
Search:   Advanced Search

Search only in Tech Issues


New posts No new posts
Closed, new posts Closed, no new posts
Moved, new posts Moved, no new posts

Adjust text size:

© 2017 CWI, Inc. © 2017 Good Sam Enterprises, LLC. All Rights Reserved. | Terms of Use | PRIVACY POLICY | YOUR PRIVACY RIGHTS