Good Sam Club Open Roads Forum: Tow Vehicles: Ram DEF guage problem
Open Roads Forum Already a member? Login here.   If not, Register Today!  |  Help

Newest  |  Active  |  Popular  |  RVing FAQ Forum Rules  |  Forum Posting Help and Support  |  Contact  

Search:   Advanced Search

Search only in Tow Vehicles

Open Roads Forum  >  Tow Vehicles

 > Ram DEF guage problem

Reply to Topic  |  Subscribe  |  Print Topic  |  Post New Topic  | 
Page of 2  
Prev
Jim2007

Greeley, Colorado

Senior Member

Joined: 01/18/2007

View Profile



Good Sam RV Club Member

Offline
Posted: 01/13/18 08:11pm Link  |  Quote  |  Print  |  Notify Moderator

My gauge works but it will stay on full a long time then make a sudden drop to three fourth... When towing I need about two and a half gallons for every 750 miles. Jim2007.


TV: 2016 Dodge 2500 Diesel
Rig: 2013 Heartland, Sundance, 5th wheel

leatherhead612

NC

Full Member

Joined: 07/11/2011

View Profile



Good Sam RV Club Member

Offline
Posted: 01/13/18 09:16pm Link  |  Quote  |  Print  |  Notify Moderator

Learjet
Thanks for the link

Jim2007

Greeley, Colorado

Senior Member

Joined: 01/18/2007

View Profile



Good Sam RV Club Member

Offline
Posted: 01/14/18 01:29pm Link  |  Quote  |  Print  |  Notify Moderator

Hi learjet... Thanks for the education. Jim2007.

proxim2020

Houston

Senior Member

Joined: 05/05/2007

View Profile


Offline
Posted: 01/15/18 07:37am Link  |  Quote  |  Print  |  Notify Moderator

Learjet wrote:



That is the way it is designed...the gauge is not linear...see below

https://youtu.be/czJZuc8ThhI


That's a good explanation. Thanks for the link.

tinner12002

Lafayette Ind

Senior Member

Joined: 10/14/2005

View Profile


Offline
Posted: 01/15/18 07:46am Link  |  Quote  |  Print  |  Notify Moderator

No issues with my gauge as it seems to be working as it should. It did flash a brief message at me the other day that def needed service but didn't store it in my messages. Called dealer and he said if it said 125 miles till limp mode to get it to them and he would get me right in. That was over a week ago and haven't seen anymore messages.


2015 Ram 3500/DRW/Aisin/auto/Max tow/4.10s,Cummins, stock Laramie Limited--Silver
Tequila Sunrise 2012 Ultra Classic Limited
2018 Raptor 428SP

spoon059

Just north of D.C.

Senior Member

Joined: 10/03/2010

View Profile



Good Sam RV Club Member

Offline
Posted: 01/15/18 08:11am Link  |  Quote  |  Print  |  Notify Moderator

tinner12002 wrote:

No issues with my gauge as it seems to be working as it should. It did flash a brief message at me the other day that def needed service but didn't store it in my messages. Called dealer and he said if it said 125 miles till limp mode to get it to them and he would get me right in. That was over a week ago and haven't seen anymore messages.

I went through that a couple times, usually right after filling up with DEF. Turns out a sensor was bad, replaced easily and under warranty with no issues.


2015 Ram CTD
2015 Jayco 29QBS

tinner12002

Lafayette Ind

Senior Member

Joined: 10/14/2005

View Profile


Offline
Posted: 01/16/18 05:48am Link  |  Quote  |  Print  |  Notify Moderator

spoon059 wrote:

tinner12002 wrote:

No issues with my gauge as it seems to be working as it should. It did flash a brief message at me the other day that def needed service but didn't store it in my messages. Called dealer and he said if it said 125 miles till limp mode to get it to them and he would get me right in. That was over a week ago and haven't seen anymore messages.

I went through that a couple times, usually right after filling up with DEF. Turns out a sensor was bad, replaced easily and under warranty with no issues.


I just attributed it to the cold weather as it hasn't done it since then, gauge was at a little over 1/2 so I hadn't filled lately. I will be keeping an eye on it though.

cummins2014

Utah

Senior Member

Joined: 02/20/2008

View Profile



Good Sam RV Club Member

Offline
Posted: 01/16/18 09:24am Link  |  Quote  |  Print  |  Notify Moderator

spoon059 wrote:

tinner12002 wrote:

No issues with my gauge as it seems to be working as it should. It did flash a brief message at me the other day that def needed service but didn't store it in my messages. Called dealer and he said if it said 125 miles till limp mode to get it to them and he would get me right in. That was over a week ago and haven't seen anymore messages.

I went through that a couple times, usually right after filling up with DEF. Turns out a sensor was bad, replaced easily and under warranty with no issues.



Same here , two times so far, after filling got the warning, and the limp mode, both went away at about the 80 mile mark. CEL remained on . Great system, I hold my breath every time I fill the DEF.

I'm just wondering when its going to stay in limp mode, and I won't be able to reach a dealer, so far I have been lucky.

1320Fastback

Vista, Ca

Senior Member

Joined: 12/04/2016

View Profile


Offline
Posted: 01/17/18 01:19pm Link  |  Quote  |  Print  |  Notify Moderator

and now my new machine at work with 654 hours on it will be getting a new complete DEF tank unit installed tomorrow.
https://imgur.com/gallery/HwIYd


1992 D250 Cummins, 5spd, 4"' straight piped, sensors deleted, airbags, DAP injectors, 18cm.


leatherhead612

NC

Full Member

Joined: 07/11/2011

View Profile



Good Sam RV Club Member

Offline
Posted: 01/25/18 02:55pm Link  |  Quote  |  Print  |  Notify Moderator

Guage has been working fine, however check engine light indicated "low reductant". Took it dealer today, replaced the DEF pump under warranty. Claimed it would have been a $2000 repair.

Reply to Topic  |  Subscribe  |  Print Topic  |  Post New Topic  | 
Page of 2  
Prev

Open Roads Forum  >  Tow Vehicles

 > Ram DEF guage problem
Search:   Advanced Search

Search only in Tow Vehicles


New posts No new posts
Closed, new posts Closed, no new posts
Moved, new posts Moved, no new posts

Adjust text size:

© 2018 CWI, Inc. © 2018 Good Sam Enterprises, LLC. All Rights Reserved. | Terms of Use | PRIVACY POLICY | YOUR PRIVACY RIGHTS