Good Sam Club Open Roads Forum: Class A Motorhomes: Front ac not responding
Open Roads Forum Already a member? Login here.   If not, Register Today!  |  Help

Newest  |  Active  |  Popular  |  RVing FAQ Forum Rules  |  Forum Posting Help and Support  |  Contact  

Search:   Advanced Search

Search only in Class A Motorhomes

Open Roads Forum  >  Class A Motorhomes  >  General Topics

 > Front ac not responding

Reply to Topic  |  Subscribe  |  Print Topic  |  Post New Topic  | 
Page of 2  
Next
Goldencrazy

madison wi

Senior Member

Joined: 06/21/2007

View Profile



Good Sam RV Club Member

Offline
Posted: 02/08/18 06:58pm Link  |  Quote  |  Print  |  Notify Moderator

2013 itasca ellipse. 3 ac units. The rear-bathroom and bedroom works well, the middle galley and living also works fine. The front does not respond to thermostat commands on ac or electric heat. Thermostat shows all commands but nothing fro the front ac. Any thoughts?

siggyd777

Northern Illinois

Senior Member

Joined: 01/19/2005

View Profile



Good Sam RV Club Member


Posted: 02/08/18 07:09pm Link  |  Quote  |  Print  |  Notify Moderator

I would check the breaker for the front AC , it may not have 120 volt AC power, the control circuits work on 12 volt DC ?
Siggy


Happy Trails
Siggy & Ursula
2011 Dutch Star 4020,ISL 400,Compr.brake,FTL XCR,IFS
Allison MH3000
2015 Jeep Cherokee,4x4 Active Drive II,V6 , Brake Buddy,Roadmaster Sterling,
Camping since 1975 Pop-Up,1986 22Ft.TT,1999 Gas MH,2005 KSDP,
2011 DSDP,FMCA 368283


fischer

livingston, tx

Senior Member

Joined: 08/02/2005

View Profile





Offline
Posted: 02/08/18 09:11pm Link  |  Quote  |  Print  |  Notify Moderator

Try selecting fan only. The Fan needs to be able to run for the a.c. to work


2016 Winnebago 35B v10
2006 Jeep Liberty 4x4
Blue ox Tow Bar

2chiefsRus

USA Somewhere

Senior Member

Joined: 09/08/2004

View Profile





Offline
Posted: 02/09/18 03:53am Link  |  Quote  |  Print  |  Notify Moderator

Is this a coach you are familiar with - i.e. did it work before and just stop working? Or is this a coach that you have never seen before and you are trying to figure out how to operate the controls?


Dave & Kathy
2007 Monaco Knight 40PDQ towing 2018 Ford F-150 & 2017 Harley Trike
Fulltime since October 2007
Before you give someone a piece of your mind, make sure you can get by with what will be left.
Our Blog
National Parks Visited

Goldencrazy

madison wi

Senior Member

Joined: 06/21/2007

View Profile



Good Sam RV Club Member

Offline
Posted: 02/09/18 06:06am Link  |  Quote  |  Print  |  Notify Moderator

The coach is new to me. Learning. First time for three. The two that work cool the coach well so i didn’t notice it was not on. Breakers are ok and fan only does not work either. Thinking thermostat issue.

bullydogs1

OBX, NC

Senior Member

Joined: 06/26/2006

View Profile


Offline
Posted: 02/09/18 06:54am Link  |  Quote  |  Print  |  Notify Moderator

Try a 12 v reset....either cut off 12 v with switch or find 12 v fuse for thermostat....turn off for 30 seconds then turn on again...works for Entegras....


Stuart and Stella Denning
2016 Entegra Aspire 42RBQ
The 3 Bulldogs (Daisy, Sylvie and Stashie)
2018 Equinox Diesel (TOAD)


Goldencrazy

madison wi

Senior Member

Joined: 06/21/2007

View Profile



Good Sam RV Club Member

Offline
Posted: 02/09/18 09:40am Link  |  Quote  |  Print  |  Notify Moderator

Thanks. When i get back i will give it a try. I flipped the breaker earlier but didn’t wait for reset time.

Goldencrazy

madison wi

Senior Member

Joined: 06/21/2007

View Profile



Good Sam RV Club Member

Offline
Posted: 02/09/18 10:43am Link  |  Quote  |  Print  |  Notify Moderator

I turned off breaker and waited over a minute as my phone rang so a good amount of time. Flipper breaker back on and the AC is working greater. Thank you so much for the tip and all the others who guided me in the right direction. Sure makes a difference. The center ac now turns off from reaching setpoint with hot sun beating on us. The front sensor is located on slide wall on drivers side. Original owner installed a 55 inch curve screen on an arm and it traps TV heat behind the tv where the sensor is located. Just hot enough to register 83 when TV is on so mannual operation for this one. That is not a problem. I suppose i can set at 83 and see how that works. Thanks again to all and Bullydogs1 for taking the time to share your knowlege.

LVJ58

Las Vegas, Nevada

Senior Member

Joined: 02/26/2001

View Profile



Good Sam RV Club Member

Offline
Posted: 02/09/18 11:07am Link  |  Quote  |  Print  |  Notify Moderator

Goldencrazy wrote:

The coach is new to me. Learning. First time for three. The two that work cool the coach well so i didn’t notice it was not on. Breakers are ok and fan only does not work either. Thinking thermostat issue.


Our coach has the Dometic Brisk Aire units and had the same problem with the bedroom AC unit. Turned out to be a bad control module on the unit.

Unfortunately the module for the 4 button T-stat was no longer available so had to have both modules replaced and new 12 button T-stat installed. A rather expensive repair.

That might be your problem, but not sure.

Good luck finding the fix and let us know what it was.

Travel Safe....[emoticon]


Jim & Sherry Seward
Las Vegas, NV
2000 Residency 3790 V-10 w/tags & Banks System
2003 Suzuki XL/7 toad

Goldencrazy

madison wi

Senior Member

Joined: 06/21/2007

View Profile



Good Sam RV Club Member

Offline
Posted: 02/09/18 01:43pm Link  |  Quote  |  Print  |  Notify Moderator

Thanks LVJ. Note above fix.

Reply to Topic  |  Subscribe  |  Print Topic  |  Post New Topic  | 
Page of 2  
Next

Open Roads Forum  >  Class A Motorhomes  >  General Topics

 > Front ac not responding
Search:   Advanced Search

Search only in Class A Motorhomes


New posts No new posts
Closed, new posts Closed, no new posts
Moved, new posts Moved, no new posts

Adjust text size:

© 2018 CWI, Inc. © 2018 Good Sam Enterprises, LLC. All Rights Reserved. | Terms of Use | PRIVACY POLICY | YOUR PRIVACY RIGHTS