Good Sam Club Open Roads Forum: Tech Issues: Hot water heater
Open Roads Forum Already a member? Login here.   If not, Register Today!  |  Help

Newest  |  Active  |  Popular  |  RVing FAQ Forum Rules  |  Forum Posting Help and Support  |  Contact  

Search:   Advanced Search

Search only in Tech Issues

Open Roads Forum  >  Tech Issues

 > Hot water heater

Reply to Topic  |  Subscribe  |  Print Topic  |  Post New Topic  | 
Kaptchinskie

Texas

New Member

Joined: 05/28/2018

View Profile


Offline
Posted: 05/30/18 11:15am Link  |  Quote  |  Print  |  Notify Moderator

I went camping last weekend and had an issue with hot water heater. It fired up fine when i first turned it on, but after a few hours the DIS light would be on. If i turned it off and on again, it would heat up again, but would never kick back on. Any ideas on what would cause this . Thermostat Sensors maybe.

Did you see the "Announcement : ★★READ BEFORE POSTING HERE★★" at the top?
    Forum Posting Help and Support is reserved for how-to question related to forum posting, signature and photo testing, or reporting member account issues. Please avoid using Forum Posting Help and Support for RV related questions, as doing so can delay responses to your thread. Instead, go to the RV Forum which corresponds to the subject of your topic, and click the Post New Topic link. Thank-you!


* This post was edited 05/30/18 07:26pm by an administrator/moderator *

wildtoad

Blythewood, SC

Senior Member

Joined: 06/05/2011

View Profile



Good Sam RV Club Member

Offline
Posted: 05/30/18 11:22am Link  |  Quote  |  Print  |  Notify Moderator

I suspect you have a bad thermostat and what is happening is the ECO (emergency cut off) is what is turning the heater off. When you turn it off it resets. Is the water extra hot?


Tom Wilds
Blythewood, SC
2016 Newmar Baystar Sport 3004

Kaptchinskie

Texas

New Member

Joined: 05/28/2018

View Profile


Offline
Posted: 05/30/18 11:31am Link  |  Quote  |  Print  |  Notify Moderator

I did not think to even check how hot the water was getting when it heat up. once i could tell it was getting hot i turned it off.

1492

Washington, DC

Moderator

Joined: 04/08/2005

View Profile



Posted: 05/31/18 06:03pm Link  |  Quote  |  Print  |  Notify Moderator

Moved from FORUM POSTING HELP AND SUPPORT

dougrainer

Carrolton, Texas

Senior Member

Joined: 06/11/2007

View Profile


Offline
Posted: 05/31/18 07:09pm Link  |  Quote  |  Print  |  Notify Moderator

wildtoad wrote:

I suspect you have a bad thermostat and what is happening is the ECO (emergency cut off) is what is turning the heater off. When you turn it off it resets. Is the water extra hot?


When the tstat fails and the ECO kicks out, the Pop Off valve usually drips/spews. The tstat is probably bad, but not the ECO. The tstat is doing its job one time and not closing after the first cycle. Doug

Kaptchinskie

Texas

New Member

Joined: 05/28/2018

View Profile


Offline
Posted: 06/09/18 11:42am Link  |  Quote  |  Print  |  Notify Moderator

I replaced the tstat and ECO today. No change. The hot water heater lights the first time it is turned on but one it goes out will not relight. I do here a humming noise from the control box. I guess bthat could be my issue. Any other suggestions?

dougrainer

Carrolton, Texas

Senior Member

Joined: 06/11/2007

View Profile


Offline
Posted: 06/09/18 12:17pm Link  |  Quote  |  Print  |  Notify Moderator

OK, you need to check for 12 volts on each side of the brown wires at the tstat. IF you have 12 volts on each side the Ignition module is bad. If you do NOT have 12 volts on each side and the water IS not hot, then the new tstat is bad. Did the Rede fault light come ON this time? The humming noise is normal for an Atwood ignition module. Doug

Reply to Topic  |  Subscribe  |  Print Topic  |  Post New Topic  | 

Open Roads Forum  >  Tech Issues

 > Hot water heater
Search:   Advanced Search

Search only in Tech Issues


New posts No new posts
Closed, new posts Closed, no new posts
Moved, new posts Moved, no new posts

Adjust text size:

© 2018 CWI, Inc. © 2018 Good Sam Enterprises, LLC. All Rights Reserved. | Terms of Use | PRIVACY POLICY | YOUR PRIVACY RIGHTS