Good Sam Club Open Roads Forum: Suburban water heater wont relight after first start
Open Roads Forum Already a member? Login here.   If not, Register Today!  |  Help

Newest  |  Active  |  Popular  |  RVing FAQ Forum Rules  |  Forum Posting Help and Support  |  Contact  

Search:   Advanced Search

Search only in Tech Issues

Open Roads Forum  >  Tech Issues

 > Suburban water heater wont relight after first start

Reply to Topic  |  Subscribe  |  Print Topic  |  Post New Topic  | 
Page of 2  
Prev
ken56

Tennessee

Senior Member

Joined: 01/12/2013

View Profile



Good Sam RV Club Member

Offline
Posted: 07/12/18 05:57am Link  |  Quote  |  Print  |  Notify Moderator

Is Suburban having an issue with bad circuit boards? Just had to have mine replaced only 1 year old. Gas side kept going into reset after lighting off and running for 10-15 minutes or so, then remained in reset condition. Like you I had to turn off the switch and back on again, would light off and get to temp, kick into reset again.

enblethen

Moses Lake, WA

Senior Member

Joined: 01/05/2005

View Profile






Posted: 07/12/18 06:48am Link  |  Quote  |  Print  |  Notify Moderator

It could be same issue as Smokeskull.
I do not believe Suburban is having any more issues then the rest of the products using circuit boards.
Make sure all connections are tight.
I would also look at the gas valve ground connection.


Bud
USAF Retired
Pace Arrow

2003 Chev Ice Road Tracker


Reply to Topic  |  Subscribe  |  Print Topic  |  Post New Topic  | 
Page of 2  
Prev

Open Roads Forum  >  Tech Issues

 > Suburban water heater wont relight after first start
Search:   Advanced Search

Search only in Tech Issues


New posts No new posts
Closed, new posts Closed, no new posts
Moved, new posts Moved, no new posts

Adjust text size:

© 2018 CWI, Inc. © 2018 Good Sam Enterprises, LLC. All Rights Reserved. | Terms of Use | PRIVACY POLICY | YOUR PRIVACY RIGHTS