Good Sam Club Open Roads Forum: Yamaha 2000 ie. running eratic
Open Roads Forum Already a member? Login here.   If not, Register Today!  |  Help

Newest  |  Active  |  Popular  |  RVing FAQ Forum Rules  |  Forum Posting Help and Support  |  Contact  

Search:   Advanced Search

Search only in General RVing Issues

Open Roads Forum  >  General RVing Issues

 > Yamaha 2000 ie. running eratic

Reply to Topic  |  Subscribe  |  Print Topic  |  Post New Topic  | 
Page of 3  
Next
ivbinconned

highway 16

Senior Member

Joined: 09/27/2003

View Profile



Posted: 02/15/19 05:15pm Link  |  Quote  |  Print  |  Notify Moderator

We r on our trip south and when I start it it runs ok for about 5 min then will almost die but then revs right back up again. Some times every 5 to 10 seconds or maybe 40 to 60.
Never dies completely.
I pulled choke slightly....still does it. Cracked fuel cap. Still does it. Turned off eco switch. Still does it.
Under big load still does it??


Ram and 34 ft Cedar Creek

GordonThree

Northern Michigan

Senior Member

Joined: 05/19/2013

View Profile


Offline
Posted: 02/15/19 05:38pm Link  |  Quote  |  Print  |  Notify Moderator

Check the oil. Mine do that when the oil is close to being too low.


2013 KZ Sportsmen Classic 200, 20 ft TT
2017 Ram 2500 4x4, 6.4 HEMI, 4.10 / Auto

azrving

Oatman

Senior Member

Joined: 05/17/2013

View Profile



Posted: 02/15/19 06:06pm Link  |  Quote  |  Print  |  Notify Moderator

As G3 said, then if still having problems try some seafoam fuel treatment.

pianotuna

Regina, SK, Canada

Senior Member

Joined: 12/18/2004

View Profile


Offline
Posted: 02/15/19 06:12pm Link  |  Quote  |  Print  |  Notify Moderator

A third vote for some Seafoam. I treat mine before storage.


Regards, Don
My ride is a 28 foot Class C, 256 watts solar, 556 amp hours of AGM in two battery banks 12 volt batteries, 3000 watt Magnum hybrid inverter, Sola Basic Autoformer, Microair Easy Start.

ScottG

Bothell Wa.

Senior Member

Joined: 02/25/2005

View Profile


Online
Posted: 02/15/19 07:14pm Link  |  Quote  |  Print  |  Notify Moderator

My Honda ran like garbage from new until I put a half a can of Seafoam in a tank of fuel and ran it for 6 hours straight.
After that it finally ran like "new".


Scott, Grace and Wesly
2003 Dodge 3500 4x4, 6 speed Cummins.
2018 Silver Fox 32A.
H0NDA eu2000i

ivbinconned

highway 16

Senior Member

Joined: 09/27/2003

View Profile



Posted: 02/15/19 09:43pm Link  |  Quote  |  Print  |  Notify Moderator

Sea foam. Just picked some up.
I’ll let you know. NEver checked oil level but will.

owenssailor

Ontario

Senior Member

Joined: 05/21/2012

View Profile



Good Sam RV Club Member

Offline
Posted: 02/15/19 10:37pm Link  |  Quote  |  Print  |  Notify Moderator

I put fuel treatment in all gas that goes into any of the small engines that I have. My new John Deere tractor actually specified that in the manual


2011 Jayco 28U
2012 Chev Silverado Crew Cab 5.3 6 spd 3.42 (sold)
2017 Chev Silverado Crew Cab 5.3 8 spd 3.42
Equal-i-Zer 1400/14000
RotoChocks


FF286

SE Tennessee

Full Member

Joined: 07/30/2017

View Profile


Offline
Posted: 02/16/19 03:54am Link  |  Quote  |  Print  |  Notify Moderator

Definitely check the oil. When I first bought my Yamaha 2000 it was burning oil, and it would do this exact thing. I never expected the oil would be low so quick but I went out and watched it and there is a red light that would come as It sputtered.

nypatnva

Amelia Ct Hse Va

Senior Member

Joined: 11/19/2005

View Profile


Offline
Posted: 02/16/19 06:33am Link  |  Quote  |  Print  |  Notify Moderator

Mine did that, changed the air filter, runs great. Yamaha's have a crappy filter


2016 dodge ram
champion generator 1978 Serro Scotty Highlander (restored)

ivbinconned

highway 16

Senior Member

Joined: 09/27/2003

View Profile



Posted: 02/16/19 11:07am Link  |  Quote  |  Print  |  Notify Moderator

Oil may be low. Sitting on flat surface I have to tip it a bit to see oil. To change do you suck it out?
What kind of oil should I replace with. Syn or regular.

Reply to Topic  |  Subscribe  |  Print Topic  |  Post New Topic  | 
Page of 3  
Next

Open Roads Forum  >  General RVing Issues

 > Yamaha 2000 ie. running eratic
Search:   Advanced Search

Search only in General RVing Issues


New posts No new posts
Closed, new posts Closed, no new posts
Moved, new posts Moved, no new posts

Adjust text size:

© 2019 CWI, Inc. © 2019 Good Sam Enterprises, LLC. All Rights Reserved. | Terms of Use | PRIVACY POLICY | YOUR PRIVACY RIGHTS