Good Sam Club Open Roads Forum: UPDATE: Hard starting Cummins ISM
Open Roads Forum Already a member? Login here.   If not, Register Today!  |  Help

Newest  |  Active  |  Popular  |  RVing FAQ Forum Rules  |  Forum Posting Help and Support  |  Contact  

Search:   Advanced Search

Search only in Class A Motorhomes

Open Roads Forum  >  Class A Motorhomes  >  All

 > UPDATE: Hard starting Cummins ISM

Reply to Topic  |  Subscribe  |  Print Topic  |  Post New Topic  | 
Page of 2  
Prev
Executive

California/Arizona/South Dakota

Senior Member

Joined: 02/07/2008

View Profile





Offline
Posted: 04/15/19 01:04pm Link  |  Quote  |  Print  |  Notify Moderator

11178adm wrote:

the most likely cause is the wrong engine mounted fuel filter. The cummins N14, M11 and ISM engine fuel filter must have a metal tube down the center of the filter or they will have long crank time. There are a lot of filters that will screw onto the cummins filter base but whatever they installed should cross to fleetgard number FS1000


Thanks everyone again. After purging the system several times yesterday, I took the coach back to the shop this morning and advised them of the above and the other suggestions. They assured me they would fix it. I'm picking it up tomorrow and I'll post the results.

Thanks again for the sage advice....Dennis


A Simple Act of Caring Creates an Endless Ripple
Dennis and Debi Ten Years Full Timing
Monaco Executive M-45PBQ Quad Slide
525HP Cummins ISM 6 Spd Allison
2014 Chevrolet Equinox LTZ W/ ReadyBrute
CLICK HERE TO VIEW OUR TRAVEL BLOG



Executive

California/Arizona/South Dakota

Senior Member

Joined: 02/07/2008

View Profile





Offline
Posted: 04/17/19 10:31am Link  |  Quote  |  Print  |  Notify Moderator

Picked up the coach last night and it's fixed. When they put on the new filters one of the "O" rings didn't get seated correctly. Removed the filter, put on a new O ring and all is good again. Thanks everyone for your advice....Dennis

2 many 2

USA

Senior Member

Joined: 06/25/2015

View Profile



Posted: 04/17/19 03:52pm Link  |  Quote  |  Print  |  Notify Moderator

Thank you for coming back with the results, congrats on an easy fix! [emoticon]

wildmanbaker

Kennewick, Washington

Senior Member

Joined: 02/24/2005

View Profile






Posted: 04/18/19 09:19am Link  |  Quote  |  Print  |  Notify Moderator

Yes, thanks for getting back with the results. As you know, not everybody does. You are a valued member of this Forum.


Wildmanbaker


wildmanbaker

Kennewick, Washington

Senior Member

Joined: 02/24/2005

View Profile






Posted: 04/18/19 09:20am Link  |  Quote  |  Print  |  Notify Moderator

And I still like the "Low Rider" picture of your MH in your sig.

Executive

California/Arizona/South Dakota

Senior Member

Joined: 02/07/2008

View Profile





Offline
Posted: 04/18/19 09:22pm Link  |  Quote  |  Print  |  Notify Moderator

wildmanbaker wrote:

And I still like the "Low Rider" picture of your MH in your sig.


[emoticon] Air leveling.

Reply to Topic  |  Subscribe  |  Print Topic  |  Post New Topic  | 
Page of 2  
Prev

Open Roads Forum  >  Class A Motorhomes  >  All

 > UPDATE: Hard starting Cummins ISM
Search:   Advanced Search

Search only in Class A Motorhomes


New posts No new posts
Closed, new posts Closed, no new posts
Moved, new posts Moved, no new posts

Adjust text size:

© 2019 CWI, Inc. © 2019 Good Sam Enterprises, LLC. All Rights Reserved. | Terms of Use | PRIVACY POLICY | YOUR PRIVACY RIGHTS