Good Sam Club Open Roads Forum: Travel Trailers: 2005 keystone sprinter
Open Roads Forum Already a member? Login here.   If not, Register Today!  |  Help

Newest  |  Active  |  Popular  |  RVing FAQ Forum Rules  |  Forum Posting Help and Support  |  Contact  

Search:   Advanced Search

Search only in Travel Trailers

Open Roads Forum  >  Travel Trailers  >  General Q&A

 > 2005 keystone sprinter

Reply to Topic  |  Subscribe  |  Print Topic  |  Post New Topic  | 
Coachmike57

Colorado

New Member

Joined: 06/01/2019

View Profile


Offline
Posted: 06/01/19 07:53pm Link  |  Quote  |  Print  |  Notify Moderator

Ok, I have a weird situation. Getting ready to leave for the weekend and I noticed I didn’t have trailer brakes or stop, running and turn lights. After investigation I found that I had the ground (white) and my harness leading to my holding tank had been ripped to shreds, also found that the wiring to my slide out motor was broken. All appeared to be pulled on very hard. All wiring is protected by a under carriage cover. Looked at everything that could have possibly caused this. Just baffled! Anyone have any issues like this?

6.2Superduty

ofallon mo

New Member

Joined: 04/15/2018

View Profile


Offline
Posted: 06/03/19 07:48pm Link  |  Quote  |  Print  |  Notify Moderator

Mice?

Reply to Topic  |  Subscribe  |  Print Topic  |  Post New Topic  | 

Open Roads Forum  >  Travel Trailers  >  General Q&A

 > 2005 keystone sprinter
Search:   Advanced Search

Search only in Travel Trailers


New posts No new posts
Closed, new posts Closed, no new posts
Moved, new posts Moved, no new posts

Adjust text size:




© 2020 CWI, Inc. © 2020 Good Sam Enterprises, LLC. All Rights Reserved.