Good Sam Club Open Roads Forum: RV Kwik Step Not coming IN
Open Roads Forum Already a member? Login here.   If not, Register Today!  |  Help

Newest  |  Active  |  Popular  |  RVing FAQ Forum Rules  |  Forum Posting Help and Support  |  Contact  

Search:   Advanced Search

Search only in Tech Issues

Open Roads Forum  >  Tech Issues

 > RV Kwik Step Not coming IN

Reply to Topic  |  Subscribe  |  Print Topic  |  Post New Topic  | 
Page of 2  
Next
vjswhippet

Cleveland, MO

Full Member

Joined: 06/09/2002

View Profile



Good Sam RV Club Member

Offline
Posted: 07/01/19 09:03am Link  |  Quote  |  Print  |  Notify Moderator

So now what ? Is there a way to retract the step manually ?


Vickie Smith
Kansas City area
2008 Gulf Stream Vista Cruiser Mini 4230


DFord

Near St Louis, MO

Senior Member

Joined: 12/16/2001

View Profile





Offline
Posted: 07/01/19 09:31am Link  |  Quote  |  Print  |  Notify Moderator

More info needed to give a good answer. Does the step try to move at all? Can you hear the motor trying to move the step?

Push comes to shove, you'll need to get under the step and remove the cotter key on the linkage so the step will move and then push it in and tie them up with a rope or bungie cord.


Don Ford
2004 Safari Trek 31SBD (F53/V10 20,500GVW)
'09 HHR 2LT or '97 Aerostar MiniVan (Remco driveshaft disconnect) for Towed vehicles
BlueOx Aventa II Towbar - ReadyBrake Inertia Brake System


vjswhippet

Cleveland, MO

Full Member

Joined: 06/09/2002

View Profile



Good Sam RV Club Member

Offline
Posted: 07/01/19 09:52am Link  |  Quote  |  Print  |  Notify Moderator

DFord wrote:

More info needed to give a good answer. Does the step try to move at all? Can you hear the motor trying to move the step?

Push comes to shove, you'll need to get under the step and remove the cotter key on the linkage so the step will move and then push it in and tie them up with a rope or bungie cord.


it's not doing anything. I'm wondering .... we found a lose wire thinking it was to the under the step light that did not work. That didn't fix the light, nor trying a new bulb. Could it be that wire didn't go to the light and has overridden something? When hubby gets home he'll undo that wire since it worked before we connected it ?

dougrainer

Carrolton, Texas

Senior Member

Joined: 06/11/2007

View Profile


Offline
Posted: 07/01/19 10:08am Link  |  Quote  |  Print  |  Notify Moderator

That wire is NOT connected to anything. It is for the OEM optional wall switch control for the step light. Odds are the motor has a dead spot. Open and close the door with the engine running. IF the under amber step light goes ON and OFF when opening and closing the door. the wiring and control are OK, You have a bad motor. Doug

DFord

Near St Louis, MO

Senior Member

Joined: 12/16/2001

View Profile





Offline
Posted: 07/01/19 10:33am Link  |  Quote  |  Print  |  Notify Moderator

Look through this webpage for information about your steps:
https://support.lci1.com/kwikee-steps

DFord

Near St Louis, MO

Senior Member

Joined: 12/16/2001

View Profile





Offline
Posted: 07/01/19 10:39am Link  |  Quote  |  Print  |  Notify Moderator

If it is the motor as Doug suggests, often you can get a few more operations from it by striking the gear motor with a hammer. If it starts working after doing that, it would be a sure sign the brushes in the motor are worn out. If that's the case, you can get a replacement motor through an auto parts store. It's the same motor as used for power windows in older cars built by Ford. If you can figure out the model number of your steps, we might be able to give you a part number for the replacement. Or you could go to an RV supply store and pay about 5 times more for it.

vjswhippet

Cleveland, MO

Full Member

Joined: 06/09/2002

View Profile



Good Sam RV Club Member

Offline
Posted: 07/01/19 10:52am Link  |  Quote  |  Print  |  Notify Moderator

dougrainer wrote:

That wire is NOT connected to anything. It is for the OEM optional wall switch control for the step light. Odds are the motor has a dead spot. Open and close the door with the engine running. IF the under amber step light goes ON and OFF when opening and closing the door. the wiring and control are OK, You have a bad motor. Doug


The amber step light was what we were initially trying to fix when we found the loose wire. It wasn't working in the first place.

ksg5000

Oregon

Senior Member

Joined: 06/30/2008

View Profile



Posted: 07/01/19 02:34pm Link  |  Quote  |  Print  |  Notify Moderator

The swing arm of the motor which connects to the step is held in place with a round metal bar which has a cotter pin on the end .. remove the cotter pin and bar and the step can be moved manually. Sometimes rapping the motor will resolve problem with dead spot on the motor.


Kevin

vjswhippet

Cleveland, MO

Full Member

Joined: 06/09/2002

View Profile



Good Sam RV Club Member

Offline
Posted: 07/01/19 03:00pm Link  |  Quote  |  Print  |  Notify Moderator

ksg5000 wrote:

The swing arm of the motor which connects to the step is held in place with a round metal bar which has a cotter pin on the end .. remove the cotter pin and bar and the step can be moved manually. Sometimes rapping the motor will resolve problem with dead spot on the motor.


Thank you !! That's what I'd need to know to do if I was out by myself.....

vjswhippet

Cleveland, MO

Full Member

Joined: 06/09/2002

View Profile



Good Sam RV Club Member

Offline
Posted: 07/01/19 03:03pm Link  |  Quote  |  Print  |  Notify Moderator

PROBLEM SOLVED
Hubby came home and cut the wire we had connected thinking it was a lose wire to the step light. As soon as I started the engine it tried to move. He had to straighten it some and I sprayed with with some white lithium grease. I thought I read some where that was good to use but I don't like it. I'll stop by my local Camping World and see if the have the Kwik Lube for the step

thank you all for your responses ....

Reply to Topic  |  Subscribe  |  Print Topic  |  Post New Topic  | 
Page of 2  
Next

Open Roads Forum  >  Tech Issues

 > RV Kwik Step Not coming IN
Search:   Advanced Search

Search only in Tech Issues


New posts No new posts
Closed, new posts Closed, no new posts
Moved, new posts Moved, no new posts

Adjust text size:

© 2019 CWI, Inc. © 2019 Good Sam Enterprises, LLC. All Rights Reserved. | Terms of Use | PRIVACY POLICY | YOUR PRIVACY RIGHTS