Good Sam Club Open Roads Forum: Tech Issues: FanTastic bathroom fan?? ((UPDATE)){{{UPDATE}}}}
Open Roads Forum Already a member? Login here.   If not, Register Today!  |  Help

Newest  |  Active  |  Popular  |  RVing FAQ Forum Rules  |  Forum Posting Help and Support  |  Contact  

Search:   Advanced Search

Search only in Tech Issues

Open Roads Forum  >  Tech Issues

 > FanTastic bathroom fan?? ((UPDATE)){{{UPDATE}}}}

Reply to Topic  |  Subscribe  |  Print Topic  |  Post New Topic  | 
Page of 3  
Prev  |  Next
joelyn

Az

Senior Member

Joined: 10/26/2002

View Profile



Good Sam RV Club Member

Offline
Posted: 07/14/19 10:08am Link  |  Quote  |  Print  |  Notify Moderator

shastagary wrote:

until you take the lift motor out and see what is wrong with it you will not know. did it get wet is it worn out?
here is a replacement one one that has a video talking about it Replacement Lift Motor for Fan-Tastic Vent


Brand new motor, just replaced it about 3 months ago. I think my lift motor is the older style since it does not have the pull down handle for manual operation. My model is K6010-81.





joelyn

Az

Senior Member

Joined: 10/26/2002

View Profile



Good Sam RV Club Member

Offline
Posted: 07/14/19 10:12am Link  |  Quote  |  Print  |  Notify Moderator

wa8yxm wrote:

Almost sounds like a lubrication issue

The Pin switch people are talking about turns the FAN motor off if the lid is closed. DO not know (Since I don't have that model) if it has anything to do with the lift motor.


Thanks, will try to get out today and take the motor out and check if there is anyplace to lubricate and if so see if that helps. will let u know. only problem is its going to be 119 here today in Az. and the trailer is about 125 in there, lol.

shastagary

minnesota

Senior Member

Joined: 07/16/2007

View Profile


Offline
Posted: 07/14/19 10:51am Link  |  Quote  |  Print  |  Notify Moderator

if it has been hard for the motor to open the lid or it did not open all the way the motor may have been stopped wile still powered up causing it to over heat and now it may not have the power to open the lid as it once had.

joelyn

Az

Senior Member

Joined: 10/26/2002

View Profile



Good Sam RV Club Member

Offline
Posted: 07/17/19 02:15pm Link  |  Quote  |  Print  |  Notify Moderator

OK, tried some lube on the gears and teeth but still motor would not open and close like it should. So I contacted DOMETIC TECH SUPPORT for any suggestions and to my surprise, after explaining to the girl what was happening she had no solution so SHE SAID SHE WILL SEND ME A ENTIRE NEW LIFT MOTOR AND ARM ASSEMBLY,,,,NO CHARGE....... WOW did not expect that. Have always had pretty good experience with Dometic but they went above and beyond for me with with this matter. My hat off to them and thank you for a great experience. They stay on my list for any future purchases.
And also THANK YOU to all who responded with your suggestions and ideas to try to remedy this problem. Have Always got great help from this forum for many many years. THANKS

* This post was edited 07/18/19 01:23pm by joelyn *

2 many 2

USA

Senior Member

Joined: 06/25/2015

View Profile



Posted: 07/18/19 11:18am Link  |  Quote  |  Print  |  Notify Moderator

Thanks for getting back to this thread and posting a resolution.

I needed a switch a few years ago, the nice lady on the phone would not let me pay for it. That is incredible customer service!

[emoticon]

joelyn

Az

Senior Member

Joined: 10/26/2002

View Profile



Good Sam RV Club Member

Offline
Posted: 07/18/19 01:20pm Link  |  Quote  |  Print  |  Notify Moderator

2 many 2 wrote:

Thanks for getting back to this thread and posting a resolution.

I needed a switch a few years ago, the nice lady on the phone would not let me pay for it. That is incredible customer service!

[emoticon]


Yes indeed, there customer service is GREATTTTTTT.. Always has been with me at least. Thanks for the reply.

down home

south

Senior Member

Joined: 06/01/2008

View Profile



Good Sam RV Club Member

Offline
Posted: 07/18/19 03:13pm Link  |  Quote  |  Print  |  Notify Moderator

Another problem, is every time someone works on our RV. They pull the knob down and turn the fan on with the knob, then they must close by pushing the knob up and using the switch in the cabinets or something. Sometimes the covers are torqued down so tight to bite into the seal hard and motor struggles to open it. Other times, the knob is still down and switch won't do anything. Then other times motor will only open half way or not at all. have to open it all the way and let the motor cycle to open position and push knob up. Maybe not exactly spot on descriptions but they screw them up just about every time.

2 many 2

USA

Senior Member

Joined: 06/25/2015

View Profile



Posted: 07/18/19 04:11pm Link  |  Quote  |  Print  |  Notify Moderator

Just as an ancillary response, I am glad the OP has solved his problem (we hope) [emoticon]

I never use the automatic opening and closing switch. I am too impatient to wait for it to open or close, so, I always just pull the handle down and open or close it manually.

That's just me............[emoticon]

2 many 2

USA

Senior Member

Joined: 06/25/2015

View Profile



Posted: 07/18/19 04:18pm Link  |  Quote  |  Print  |  Notify Moderator

joelyn wrote:

2 many 2 wrote:

Thanks for getting back to this thread and posting a resolution.

I needed a switch a few years ago, the nice lady on the phone would not let me pay for it. That is incredible customer service!

[emoticon]


Yes indeed, there customer service is GREATTTTTTT.. Always has been with me at least. Thanks for the reply.


I just remembered, I ran into a guy that had a ten year old Fantastic Fan about five years ago. He was having some issues with it and I told him to call Fantastic fan and see what happens. They sent him an entire new fan! I am pretty sure that would not happen today, but he was a happy customer!!

joelyn

Az

Senior Member

Joined: 10/26/2002

View Profile



Good Sam RV Club Member

Offline
Posted: 07/18/19 04:29pm Link  |  Quote  |  Print  |  Notify Moderator

2 many 2 wrote:

Just as an ancillary response, I am glad the OP has solved his problem (we hope) [emoticon]

I never use the automatic opening and closing switch. I am too impatient to wait for it to open or close, so, I always just pull the handle down and open or close it manually.

That's just me............[emoticon]


My fan must be a older model because my handle on the left motor does not have the pull down handle to open manually. Its a fixed handle that goes right into the shaft.
this is the lift motor i have and I believe the newer models have the lift motor right above mine where the label says manual etc.. NOT SURE IF THEY ARE INTERCHANGEABLE OR NOT. Maybe someone would know. The second link is the other motor for I believe newer fans with the pull down.


lift motor K6010-81

newer lift motor

Reply to Topic  |  Subscribe  |  Print Topic  |  Post New Topic  | 
Page of 3  
Prev  |  Next

Open Roads Forum  >  Tech Issues

 > FanTastic bathroom fan?? ((UPDATE)){{{UPDATE}}}}
Search:   Advanced Search

Search only in Tech Issues


New posts No new posts
Closed, new posts Closed, no new posts
Moved, new posts Moved, no new posts

Adjust text size:

© 2019 CWI, Inc. © 2019 Good Sam Enterprises, LLC. All Rights Reserved. | Terms of Use | PRIVACY POLICY | YOUR PRIVACY RIGHTS