Good Sam Club Open Roads Forum: Almost lost a mud flap...
Open Roads Forum Already a member? Login here.   If not, Register Today!  |  Help

Newest  |  Active  |  Popular  |  RVing FAQ Forum Rules  |  Forum Posting Help and Support  |  Contact  

Search:   Advanced Search

Search only in Class A Motorhomes

Open Roads Forum  >  Class A Motorhomes  >  General Topics

 > Almost lost a mud flap...

Reply to Topic  |  Subscribe  |  Print Topic  |  Post New Topic  | 
Page of 3  
Prev
wa8yxm

Wherever I happen to park

Senior Member

Joined: 07/04/2006

View Profile


Offline
Posted: 12/26/19 04:37pm Link  |  Quote  |  Print  |  Notify Moderator

Another option is something called Mending plates. Short metal bars with usualyl 3 holes in them.. BOlt one to the bracket (Washer it up if you have to to make thigns line up right and then to the flap.. wherever needed. YOu may want to consider a hinge as well. so it can "Flap".

Things could be worse

I had the 3/4" bolt (Grade 8 of course) on my steering stablizer lose a nut and come loose.. Got a new one in a couple weeks ago this one won't come lose.. I "oiled" the threads with a special BLUE oil (Locktite)

Also one engine mount (Grade 8 7/16 by 5.5") was AWOL and the other one I took the nut off... with my fingers.. Got a grade 5 in the missing one now (Grade 8 ready when I get to an ideal site to fix) and oiled the other one with the aforementioned special oil before tightening the nut down again.

I really don't like working in tight quarters though.


Home is where I park it.
Kenwood TS-2000 housed in a 2005 Damon Intruder 377


Reply to Topic  |  Subscribe  |  Print Topic  |  Post New Topic  | 
Page of 3  
Prev

Open Roads Forum  >  Class A Motorhomes  >  General Topics

 > Almost lost a mud flap...
Search:   Advanced Search

Search only in Class A Motorhomes


New posts No new posts
Closed, new posts Closed, no new posts
Moved, new posts Moved, no new posts

Adjust text size:




© 2020 CWI, Inc. © 2020 Good Sam Enterprises, LLC. All Rights Reserved.