Good Sam Club Open Roads Forum: Tech Issues: Atwood furnace not igniting
Open Roads Forum Already a member? Login here.   If not, Register Today!  |  Help

Newest  |  Active  |  Popular  |  RVing FAQ Forum Rules  |  Forum Posting Help and Support  |  Contact  

Search:   Advanced Search

Search only in Tech Issues

Open Roads Forum  >  Tech Issues

 > Atwood furnace not igniting

Reply to Topic  |  Subscribe  |  Print Topic  |  Post New Topic  | 
Page of 2  
Prev
Mike63376

Driveway

New Member

Joined: 12/20/2019

View Profile


Offline
Posted: 12/20/19 09:39am Link  |  Quote  |  Print  |  Notify Moderator

Got the same sail switch problem. 2019 jayco. Atwood furnace gas valve won’t open. Shut it down. Removed cover (no door). Tapped on sail switch lightly. Reset and powered thermostat. Works fine for about 3 weeks. Just happened again. Do I have to remove the whole furnace to change sail switch. It has the new design. Bought another new furnace. It has the old design sail switch. What’s the problem with the sail switch. Jayco is new. New sail switch is located in blower outlet housing, old style is in combustion blower housing. Why the change in locations?

* This post was edited 12/20/19 09:48am by Mike63376 *

3 tons

NV.

Senior Member

Joined: 03/13/2009

View Profile


Offline
Posted: 12/20/19 10:36am Link  |  Quote  |  Print  |  Notify Moderator

I had a similar problem, and after examination it was not the sail switch... Turned out that theres an ignition prover (not sure if thats the proper OEM name) just above the exhaust outlet that has two electrode prongs, that over a time the gap can get outta spec due to road vibration... I pulled this out and closed the gap a bit (to about 1/4”) and all was well again... Haven't had a single recurrence in over 5 years since...

vermilye

Oswego, NY, USA

Senior Member

Joined: 08/11/2004

View Profile



Good Sam RV Club Member


Posted: 12/20/19 10:46am Link  |  Quote  |  Print  |  Notify Moderator

Mike63376 wrote:

Got the same sail switch problem. 2019 jayco. Atwood furnace gas valve won’t open. Shut it down. Removed cover (no door). Tapped on sail switch lightly. Reset and powered thermostat. Works fine for about 3 weeks. Just happened again. Do I have to remove the whole furnace to change sail switch. It has the new design. Bought another new furnace. It has the old design sail switch. What’s the problem with the sail switch. Jayco is new. New sail switch is located in blower outlet housing, old style is in combustion blower housing. Why the change in locations?
One sail switch problem many Escape Fiberglass trailer owners have been having with the Atwood AFSAD12 furnace is pet hair jamming the switch. Rather than replacing it, carefully removing the accumulation has fixed it.

The newer installations include an outside door that provides access to both the electronics & sail switch. Older models require pulling the furnace for either.


Jon Vermilye My Travel Blog
My Photo & RV link blog


Reply to Topic  |  Subscribe  |  Print Topic  |  Post New Topic  | 
Page of 2  
Prev

Open Roads Forum  >  Tech Issues

 > Atwood furnace not igniting
Search:   Advanced Search

Search only in Tech Issues


New posts No new posts
Closed, new posts Closed, no new posts
Moved, new posts Moved, no new posts

Adjust text size:




© 2020 CWI, Inc. © 2020 Good Sam Enterprises, LLC. All Rights Reserved.