Good Sam Club Open Roads Forum: Tow Vehicles: Chrysler UConnect
Open Roads Forum Already a member? Login here.   If not, Register Today!  |  Help

Newest  |  Active  |  Popular  |  RVing FAQ Forum Rules  |  Forum Posting Help and Support  |  Contact  

Search:   Advanced Search

Search only in Tow Vehicles

Open Roads Forum  >  Tow Vehicles

 > Chrysler UConnect

Reply to Topic  |  Subscribe  |  Print Topic  |  Post New Topic  | 
Page of 3  
Next
SweetLou

La Quinta, CA USA

Senior Member

Joined: 06/03/2003

View Profile


Offline
Posted: 01/07/20 06:09am Link  |  Quote  |  Print  |  Notify Moderator

I'm just curious how many people are CURRENTLY having issues with their UConnect in their vehicles? I have been for some time now and It was replaced with a new one and it still does the problem I was having. The dealer states that there are thousands with similar issues and an Over the Air fix is coming. Been months on that one. Any news?


2013 3500 Cummins 6.7 Quadcab 4x4 3.73 68FE Trans, 2007 HitchHiker Discover America 329 RSB
We love our Westie


librty02

Western Pa

Senior Member

Joined: 03/15/2009

View Profile


Offline
Posted: 01/07/20 06:44am Link  |  Quote  |  Print  |  Notify Moderator

What is your issue you are having with it???

I have a Jeep Grand Cherokee and couple Fords and I will say I like the Jeep interface much better than Fords Sync but The Sync system is soooo much smoother than the Uconnect. The Jeep can never understand what I say when I talk to it. My ford I can mumble and it will get what I say correctly. My biggest gripe is that Uconnect app etc is not free while Fords Pass App is free. Uconnect called me to set me up with an account and wanted to charge me I told them to give it to me for free like Ford does with all their vehicles and then I'll take it.


2011 FORD F-150 FX4 CREW CAB ECO...
2018 Ford F-150 Max Tow Crew 6.5 3.5 Eco...
2013 Keystone Passport 2650BH, EQUAL-I-ZER 1K/10K

ShinerBock

SATX

Senior Member

Joined: 02/22/2015

View Profile



Posted: 01/07/20 06:57am Link  |  Quote  |  Print  |  Notify Moderator

What is your issue?

I am not having issues other than is is sluggish at startup sometimes, but it normally does that when it is downloading an update. The only issue I had with it was that it would not auto-connect with my Spotify on my phone for a period of time, but that ended up being a Spotify app issue and was fixed.

Me Again

Sunbird(Wa)/snowbird(Az)

Senior Member

Joined: 09/26/2012

View Profile



Good Sam RV Club Member

Offline
Posted: 01/07/20 07:10am Link  |  Quote  |  Print  |  Notify Moderator

Mine works fine. Did the latest update myself. The GPS went nuts last summer and I had to reboot it by hold in the two radio knobs.


2015 RAM 3500 CC SB SRW Our Rig New 2017 Bighorn 3575el. Commuter trailer 2019 Laredo 225MK. Retired and enjoying it!


ScottG

Bothell Wa.

Senior Member

Joined: 02/25/2005

View Profile


Offline
Posted: 01/07/20 09:08am Link  |  Quote  |  Print  |  Notify Moderator

I've had no problems with the one in our 2015 Challenger since new.
What kind of problem are you having?


Scott, Grace and Wesly
2003 Dodge 3500 4x4, 6 speed Cummins.
2018 Silver Fox 32A.
H0NDA eu2000i

MNGeeks61

Minneapolis, MN

Senior Member

Joined: 02/10/2014

View Profile


Offline
Posted: 01/07/20 09:26am Link  |  Quote  |  Print  |  Notify Moderator

what kind of issue?

We've had to update our Uconnect once. Worked fine. Although the documentation did say to be careful or something.

In terms of what it does, the bluetooth connection to our phones work great, it reads texts fine, but the voice recognition is somewhere below Amazon's and way below Google's voice recognition. I never use it.

The maps are ok, google maps on our phones are better though. And in terms of remote start, the fob works great. Issuing a remote start command through the app takes much longer, but it is handy when you're not sure if you've forgotten to lock your doors in a large parking lot...

I have never tried Sync but my neighbor doesn't like his much. Still, his is free.

SweetLou

La Quinta, CA USA

Senior Member

Joined: 06/03/2003

View Profile


Offline
Posted: 01/07/20 09:59am Link  |  Quote  |  Print  |  Notify Moderator

My issues are volume goes away to radio or anything else you are listening to as well as some function. When you turn off the vehicle and open the door it wound't shut down like as it should. You have to reset it by putting in the key and going to accessory. It was replaced by chrysler care, but now new one is doing the samething. Dealer states that there over 300 units in th Phonix area alone with Uconnect issues. I just don't want to hear a story. I thought I would get some real time answers from some folks.

TurnThePage

North ID

Senior Member

Joined: 10/08/2003

View Profile


Offline
Posted: 01/07/20 10:01am Link  |  Quote  |  Print  |  Notify Moderator

I recently had an issue with GPS not working correctly. There was an update available to fix it, but it was failing to automatically download and install. I was able to go to the Uconnect website and download and install it myself. But some people have been unable to do that and had to manually jump through some hoops that eventually enabled them to download the correct file and fix the issue. If that's your problem, you could probably find the solution on ramforum.com.


2015 Ram 1500
2004 Pioneer 18T6

SweetLou

La Quinta, CA USA

Senior Member

Joined: 06/03/2003

View Profile


Offline
Posted: 01/07/20 10:17am Link  |  Quote  |  Print  |  Notify Moderator

TurnThePage wrote:

I recently had an issue with GPS not working correctly. There was an update available to fix it, but it was failing to automatically download and install. I was able to go to the Uconnect website and download and install it myself. But some people have been unable to do that and had to manually jump through some hoops that eventually enabled them to download the correct file and fix the issue. If that's your problem, you could probably find the solution on ramforum.com.

I would hope that being to the dealer over this they might know these tricks.

mich800

Pontiac, MI

Senior Member

Joined: 05/30/2004

View Profile



Posted: 01/07/20 12:06pm Link  |  Quote  |  Print  |  Notify Moderator

SweetLou wrote:

My issues are volume goes away to radio or anything else you are listening to as well as some function. When you turn off the vehicle and open the door it wound't shut down like as it should. You have to reset it by putting in the key and going to accessory. It was replaced by chrysler care, but now new one is doing the samething. Dealer states that there over 300 units in th Phonix area alone with Uconnect issues. I just don't want to hear a story. I thought I would get some real time answers from some folks.


They can be buggy. But two units doing the same thing would have me searching for another input that is causing the errors.

Reply to Topic  |  Subscribe  |  Print Topic  |  Post New Topic  | 
Page of 3  
Next

Open Roads Forum  >  Tow Vehicles

 > Chrysler UConnect
Search:   Advanced Search

Search only in Tow Vehicles


New posts No new posts
Closed, new posts Closed, no new posts
Moved, new posts Moved, no new posts

Adjust text size:




© 2020 CWI, Inc. © 2020 Good Sam Enterprises, LLC. All Rights Reserved.