Good Sam Club Open Roads Forum: Battery cut off not operating
Open Roads Forum Already a member? Login here.   If not, Register Today!  |  Help

Newest  |  Active  |  Popular  |  RVing FAQ Forum Rules  |  Forum Posting Help and Support  |  Contact  

Search:   Advanced Search

Search only in Class A Motorhomes

Open Roads Forum  >  Class A Motorhomes  >  Maintenance Issues & Tips

 > Battery cut off not operating

Reply to Topic  |  Subscribe  |  Print Topic  |  Post New Topic  | 
Page of 2  
Next
iamalienru

Yucaipa California

Full Member

Joined: 03/04/2013

View Profile



Good Sam RV Club Member

Offline
Posted: 04/11/20 01:16pm Link  |  Quote  |  Print  |  Notify Moderator

I have a 1998 American Eagle the chassis and coach buttons under the passenger seat is not operating thus the refrigerator is not working i have an intellitec battery control system i am getting power to the relays in control box all fuses are good breaker too brand new fridge and magnum inverter stumped does anyone know about this system could use the help thanks


Tom

K Charles

Connecticut

Senior Member

Joined: 03/06/2010

View Profile



Good Sam RV Club Member

Offline
Posted: 04/11/20 02:17pm Link  |  Quote  |  Print  |  Notify Moderator

Did the "brand new fridge and magnum inverter" ever work? How long have they been new? What else doesn't work?





iamalienru

Yucaipa California

Full Member

Joined: 03/04/2013

View Profile



Good Sam RV Club Member

Offline
Posted: 04/11/20 02:26pm Link  |  Quote  |  Print  |  Notify Moderator

Everything else works and yes they all worked just fine up until a day ago somehow the battery cut off switch is not engaging it normally illuminates when the are engaged pressing the chassis switch i hear a click coming from the control box and the light will illuminate for a second the quit hmm

K Charles

Connecticut

Senior Member

Joined: 03/06/2010

View Profile



Good Sam RV Club Member

Offline
Posted: 04/11/20 03:16pm Link  |  Quote  |  Print  |  Notify Moderator

Sounds like the latching relay is not latching

MountainAir05

New Mexico

Senior Member

Joined: 01/27/2007

View Profile


Offline
Posted: 04/11/20 03:28pm Link  |  Quote  |  Print  |  Notify Moderator

K Charles wrote:

Sounds like the latching relay is not latching


Have someone hold the switch and you hit the relay with piece of wood. Might take a few times. Clean or replace

iamalienru

Yucaipa California

Full Member

Joined: 03/04/2013

View Profile



Good Sam RV Club Member

Offline
Posted: 04/11/20 03:36pm Link  |  Quote  |  Print  |  Notify Moderator

I hope they havent changed much over the years i will be pulling the circuit board tomorrow and see what i am up against hope this does the trick

iamalienru

Yucaipa California

Full Member

Joined: 03/04/2013

View Profile



Good Sam RV Club Member

Offline
Posted: 04/11/20 04:14pm Link  |  Quote  |  Print  |  Notify Moderator

I hope they havent changed much over the years i will be pulling the circuit board tomorrow and see what i am up against hope this does the trick

winniman

muskoka Ontario

Senior Member

Joined: 01/26/2013

View Profile


Offline
Posted: 04/11/20 07:28pm Link  |  Quote  |  Print  |  Notify Moderator

Have someone hit the switch, and follow the sound of the clunk to locate the latching relay. Use a tester to see if it has power on both large terminals. As stated, if it isn't latching, you wont get any 12 volt power to the house. If no power on each side, try bypassing it to see if it corrects the issue. If it does the relay is gone. This can be done by removing one of the large wires, and pairing it up with the large one on the opposite side. I have seen them go for no reason at all. We were just sitting there and all the lights went off. We bypassed it until we could get another one a few days later.

iamalienru

Yucaipa California

Full Member

Joined: 03/04/2013

View Profile



Good Sam RV Club Member

Offline
Posted: 04/11/20 07:35pm Link  |  Quote  |  Print  |  Notify Moderator

Funny thing is i have lights the fridge is dead no gas or electric start nor on the generator when i push the chassis button i hear a click house button does nothing

wa8yxm

Wherever I happen to park

Senior Member

Joined: 07/04/2006

View Profile


Offline
Posted: 04/12/20 05:49am Link  |  Quote  |  Print  |  Notify Moderator

If you have lights odds are the disconnect is connecting properly

I had a problem not unlike yours on my Dometic. Service technician suggested a two step repair. INSIDE pull the "Eyebrow" off and unplug and re-plug the main umbicical cable.. Outside in the control box (the black box) do exactly the same thign... WORKING.


Home is where I park it.
2005 Damon Intruder 377 Alas declared a total loss
after a semi "nicked" it. Still have the radios
Kenwood TS-2000, ICOM ID-5100, ID-51A+2, ID-880 REF030C most times


Reply to Topic  |  Subscribe  |  Print Topic  |  Post New Topic  | 
Page of 2  
Next

Open Roads Forum  >  Class A Motorhomes  >  Maintenance Issues & Tips

 > Battery cut off not operating
Search:   Advanced Search

Search only in Class A Motorhomes


New posts No new posts
Closed, new posts Closed, no new posts
Moved, new posts Moved, no new posts

Adjust text size:




© 2021 CWI, Inc. © 2021 Good Sam Enterprises, LLC. All Rights Reserved.