Good Sam Club Open Roads Forum: Trouble With RV.net Am I Alone?
Open Roads Forum Already a member? Login here.   If not, Register Today!  |  Help

Newest  |  Active  |  Popular  |  RVing FAQ Forum Rules  |  Forum Posting Help and Support  |  Contact  

Search:   Advanced Search

Search only in Class C Motorhomes

Open Roads Forum  >  Class C Motorhomes  >  All

 > Trouble With RV.net Am I Alone?

Reply to Topic  |  Subscribe  |  Print Topic  |  Post New Topic  | 
Page of 3  
Prev
gkainz

Arvada, CO, USA

Senior Member

Joined: 10/02/2004

View Profile



Posted: 06/03/20 06:49am Link  |  Quote  |  Print  |  Notify Moderator

after many years and frequent performance issues, I finally abandoned RV.NET portal and switched to trailerlife.com (which I had used occasionally, years ago). Much more reliable performance.


'07 Ram 2500 CTD 4x4 Quad Cab
'10 Keystone Laredo 245 5er

Harvey51

Alberta

Senior Member

Joined: 12/11/2006

View Profile


Offline
Posted: 06/03/20 09:33am Link  |  Quote  |  Print  |  Notify Moderator

I also abandoned the RV.net address in favour of
http://forums.goodsamclub.com/
All these portals have the same members, topics and posts so you will be right at home when you switch to a less buggy portal.


2004 E350 Adventurer (Canadian) 20 footer - Alberta, Canada
No TV + 100W solar = no generator needed

Reply to Topic  |  Subscribe  |  Print Topic  |  Post New Topic  | 
Page of 3  
Prev

Open Roads Forum  >  Class C Motorhomes  >  All

 > Trouble With RV.net Am I Alone?
Search:   Advanced Search

Search only in Class C Motorhomes


New posts No new posts
Closed, new posts Closed, no new posts
Moved, new posts Moved, no new posts

Adjust text size:




© 2020 CWI, Inc. © 2020 Good Sam Enterprises, LLC. All Rights Reserved.