Good Sam Club Open Roads Forum: Electric jack for 5 wheel goes up and not down
Open Roads Forum Already a member? Login here.   If not, Register Today!  |  Help

Newest  |  Active  |  Popular  |  RVing FAQ Forum Rules  |  Forum Posting Help and Support  |  Contact  

Search:   Advanced Search

Search only in Tech Issues

Open Roads Forum  >  Tech Issues

 > Electric jack for 5 wheel goes up and not down

Reply to Topic  |  Subscribe  |  Print Topic  |  Post New Topic  | 
Page of 3  
Prev  |  Next
snowpeke

Nevada City California

Senior Member

Joined: 10/10/2004

View Profile



Good Sam RV Club Member


Posted: 05/30/20 11:19am Link  |  Quote  |  Print  |  Notify Moderator

Voltage is fine and it's been slow since new.


2002 Chevy DuraMax
2014 jayco eagle
Two Pekingese dogs

fj12ryder

Platte City, MO

Senior Member

Joined: 08/19/2003

View Profile



Posted: 05/30/20 01:49pm Link  |  Quote  |  Print  |  Notify Moderator

Well, depending on the size of the trailer, those leg motors are notoriously weak. Yours may well have given up the ghost. Try disconnecting the cross member and see if it will work with just one leg. Then try disconnecting the gearbox and see if the motor works better. You may have dry parts that just need to be lubed.

I replaced my single motor, which was slooooooow from the new, with a set of Bulldog motors and legs. A world of improvement. Worth every penny.


Howard and Peggy

"Don't Panic"

snowpeke

Nevada City California

Senior Member

Joined: 10/10/2004

View Profile



Good Sam RV Club Member


Posted: 06/04/20 07:57am Link  |  Quote  |  Print  |  Notify Moderator

Ok I replaced the switch and the same thing is there anything else besides the motor to replace?

BFL13

Victoria, BC

Senior Member

Joined: 02/15/2006

View Profile



Posted: 06/04/20 08:10am Link  |  Quote  |  Print  |  Notify Moderator

You can test the motor before having to replace that.

What I did with the slide motor was to get at the two wires it has close to the motor, cutting the insulation on both. Then I used a portable charger with clamps and found that it turned one way and then the other way with the clamps reversed. So the motor was ok.

That left a wiring issue which turned out to be the switch in my case. It was tricky wiring the switch so it would work right.

The link above has links to trouble shooting videos for the jacks.


1. 1991 Oakland 28DB Class C
on Ford E350-460-7.5 Gas EFI
See Profile for House electronics set-up.
2. 1991 Bighorn 9.5ft Truck Camper on 2003 Chev 2500HD 6.0 Gas

fj12ryder

Platte City, MO

Senior Member

Joined: 08/19/2003

View Profile



Posted: 06/04/20 08:16am Link  |  Quote  |  Print  |  Notify Moderator

snowpeke wrote:

Ok I replaced the switch and the same thing is there anything else besides the motor to replace?
Have you checked the gearbox and the bevel gears at the tops of the legs?

snowpeke

Nevada City California

Senior Member

Joined: 10/10/2004

View Profile



Good Sam RV Club Member


Posted: 06/04/20 05:25pm Link  |  Quote  |  Print  |  Notify Moderator

Here is the latest had the motor and switch checked both OK some wires go from the switch to the motor and some go in the trailer so there must bea relay somewhere in side. Looked in the fuse compartment and did not see anything that looks likes a relay. I have a 2014 jayco 26.5 RLS 5th wheel. Any ideas where to look or is a trip to the RV repair shop?

snowpeke

Nevada City California

Senior Member

Joined: 10/10/2004

View Profile



Good Sam RV Club Member


Posted: 06/04/20 05:35pm Link  |  Quote  |  Print  |  Notify Moderator

Help I have had the switch and the motor checked and are fine. Some wires go,to the switch and motor. Some go back into the trailer then come back out. There must be a bad relay some where in side.does anybody know where to look? I looked in the fuse box and did not see any relay looking like one you would see in a car. This is a 2014 jayco 26.5. Any help would be great.

snowpeke

Nevada City California

Senior Member

Joined: 10/10/2004

View Profile



Good Sam RV Club Member


Posted: 06/04/20 05:35pm Link  |  Quote  |  Print  |  Notify Moderator

Please help the switch is fine the motor is fine hav them tested. Some wires go don't go into to inside of the trailer so I think there is a relay some where inside but I don't know where it is. This is a 2014 26.5 RLS jayco where are the relay?

fj12ryder

Platte City, MO

Senior Member

Joined: 08/19/2003

View Profile



Posted: 06/04/20 06:54pm Link  |  Quote  |  Print  |  Notify Moderator

Well, if the switch and the motor are both "fine", it should work. How were they checked and determined to be "fine". Have you checked to see if there is voltage to the switch in both positions: "Retract" and "Extend"?

snowpeke

Nevada City California

Senior Member

Joined: 10/10/2004

View Profile



Good Sam RV Club Member


Posted: 06/04/20 10:08pm Link  |  Quote  |  Print  |  Notify Moderator

Where is my relay!

Reply to Topic  |  Subscribe  |  Print Topic  |  Post New Topic  | 
Page of 3  
Prev  |  Next

Open Roads Forum  >  Tech Issues

 > Electric jack for 5 wheel goes up and not down
Search:   Advanced Search

Search only in Tech Issues


New posts No new posts
Closed, new posts Closed, no new posts
Moved, new posts Moved, no new posts

Adjust text size:




© 2020 CWI, Inc. © 2020 Good Sam Enterprises, LLC. All Rights Reserved.