Good Sam Club Open Roads Forum: Travel Trailers: Tank monitor/Water heater/water pump issue
Open Roads Forum Already a member? Login here.   If not, Register Today!  |  Help

Newest  |  Active  |  Popular  |  RVing FAQ Forum Rules  |  Forum Posting Help and Support  |  Contact  

Search:   Advanced Search

Search only in Travel Trailers

Open Roads Forum  >  Travel Trailers  >  General Q&A

 > Tank monitor/Water heater/water pump issue

Reply to Topic  |  Subscribe  |  Print Topic  |  Post New Topic  | 
Page of 2  
Next
gordinho80

Central NJ

New Member

Joined: 11/17/2017

View Profile


Offline
Posted: 08/27/20 08:44pm Link  |  Quote  |  Print  |  Notify Moderator

Water heater, pump, tank level indicators, heater indicator light not working. Dim flash when hitting test. Tried to capture behavior on video in dark...
Test once, all lights dim flash
Test second, All lights dim flash
Turn on heater, heater switch indicator dim flash
Turn on pump, indicator works but pump does not kick on.

Any suggestions? Just spent 3 nights with wife, 5 yo daughter, and 13 yo niece... with no hot water for showers...


Mario
2012 Ram 1500 Crew Big Horn 5.7L Hemi (My first Dodge)
2000 Coachmen Futura 2790TB (Our first camper) - https://www.instagram.com/martin_the_camper/

Rover_Bill

NE. Ohio

Senior Member

Joined: 04/22/2016

View Profile



Good Sam RV Club Member

Offline
Posted: 08/28/20 12:11am Link  |  Quote  |  Print  |  Notify Moderator

Have you checked your battery voltage and connections?


2015 GMC Canyon 3.6L V6 4X4 TowHaul SLE ExtCab Bronze
2016 Keystone Passport GT 2670BH
ReCurve R6 hitch, DirecLink brake controller
2005 Suzuki C50 2006 Suzuki S40

midnightsadie

ohio

Senior Member

Joined: 01/07/2008

View Profile


Offline
Posted: 08/28/20 05:46am Link  |  Quote  |  Print  |  Notify Moderator

X2 sounds like your batter is dead.

rrupert

NW PA

Senior Member

Joined: 02/26/2005

View Profile


Offline
Posted: 08/28/20 05:47am Link  |  Quote  |  Print  |  Notify Moderator

A bad ground is my first thought.


Rich and Joyce
2018 Jayco Jay Flight 21QB
2012 Ford F150 4X4 Supercrew EcoBoost
Reese Strait-Line Dual Cam Hitch
Amateur Radio K3EXU


GrandpaKip

Flat Rock

Senior Member

Joined: 06/18/2013

View Profile



Good Sam RV Club Member

Offline
Posted: 08/28/20 07:14am Link  |  Quote  |  Print  |  Notify Moderator

Are you plugged into shore power or boondocking?


Kip
2015 Skyline Dart 214RB
2018 Silverado Double Cab 4x4
Andersen Hitch

gordinho80

Central NJ

New Member

Joined: 11/17/2017

View Profile


Offline
Posted: 08/28/20 09:56pm Link  |  Quote  |  Print  |  Notify Moderator

Shore power. Battery is dead and awaiting replacement. While hooked up to tow rig, everything works fine. Isn’t the converter supposed to supply 12v to certain things when needed... ie these items ?

Sjm9911

New Jersey

Senior Member

Joined: 07/01/2020

View Profile



Good Sam RV Club Member

Offline
Posted: 08/28/20 10:03pm Link  |  Quote  |  Print  |  Notify Moderator

It should unless the converter or a conection is bad, then it will not supply dc or charge the battery. Now you have to check the converter out put. You have ac power right? So you know power is coming into the camper?


2012 kz spree 220 ks
2020 Silverado 2500
Equalizer ( because i have it)
Formerly a pup owner.

GrandpaKip

Flat Rock

Senior Member

Joined: 06/18/2013

View Profile



Good Sam RV Club Member

Offline
Posted: 08/29/20 08:42am Link  |  Quote  |  Print  |  Notify Moderator

20 year old camper, with original converter? If so, it may need to be replaced.
Check output and connections.

opnspaces

San Diego Ca

Senior Member

Joined: 12/22/2004

View Profile


Offline
Posted: 08/29/20 04:39pm Link  |  Quote  |  Print  |  Notify Moderator

Converter is dead so no battery charge or lights when plugged in. Battery is dead because no converter charging it because converter is dead. Everything works when hitched up because the tow vehicle battery is supplying the 12 volts to the trailer.


2001 Suburban 4x4. 6.0L, 4.10 3/4 ton
2005 Jayco Jay Flight 27BH
1986 Coleman Columbia Popup.

gordinho80

Central NJ

New Member

Joined: 11/17/2017

View Profile


Offline
Posted: 09/04/20 07:56am Link  |  Quote  |  Print  |  Notify Moderator

Well, after digging a little deeper, looks like everything is actually in working order. Battery terminals were loose. So I tightened those down... then realized the breaker inline with the 12v wire was tripped. Reset that. After being all connected properly and hooked up to shore power for a day, battery tested 13.8v and the panel worked. Don't know if the battery will hold a charge yet... will be testing that out in coming weeks. Going to hook up a power inverter to it so I can run my residential fridge while in tow. Will disconnect shore power when I get the inverter set up and see how long the battery runs the inverter for. If we can't get a good run, at least a couple of hours, then I'll look into upgrading the battery. I'm hoping to get at least 5-6 hours of inverter/fridge run time while in tow. Maybe run larger gauge wire with some Anderson plugs to send more juice to the trailer while hooked up to tow rig.

Reply to Topic  |  Subscribe  |  Print Topic  |  Post New Topic  | 
Page of 2  
Next

Open Roads Forum  >  Travel Trailers  >  General Q&A

 > Tank monitor/Water heater/water pump issue
Search:   Advanced Search

Search only in Travel Trailers


New posts No new posts
Closed, new posts Closed, no new posts
Moved, new posts Moved, no new posts

Adjust text size:




© 2020 CWI, Inc. © 2020 Good Sam Enterprises, LLC. All Rights Reserved.