Good Sam Club Open Roads Forum: Question about my on-demand water pump and ?
Open Roads Forum Already a member? Login here.   If not, Register Today!  |  Help

Newest  |  Active  |  Popular  |  RVing FAQ Forum Rules  |  Forum Posting Help and Support  |  Contact  

Search:   Advanced Search

Search only in Truck Campers

Open Roads Forum  >  Truck Campers

 > Question about my on-demand water pump and ?

Reply to Topic  |  Subscribe  |  Print Topic  |  Post New Topic  | 
prginocx

Portland, OR.

New Member

Joined: 01/12/2006

View Profile


Offline
Posted: 09/04/20 12:43pm Link  |  Quote  |  Print  |  Notify Moderator

So I've got a '96 Pastime Cabover 8' long. My daughter left the switch on for the water pump, it was humming away this morning when I got out to the camper. So lets say it was on all night. There was water in the tank. It still seems to work 5 hours later after turning it off and letting it cool down.
Do you think there is any permanent damage ? Should I replace the pump ?

2nd topic: One of my lift jacks is a bit slower than the other three, it is noticeable when you are unloading / loading the camper, you have to run it a bit longer to keep level going up/down. My set up has electric motors on each corner, with dual switches. Two switches in rear left side, two switches front left side. so to raise / lower, you walk back and forth a bit. I'm wondering if this slower motor is the first signs of it wearing out ?

jdc1

Rescue, Ca

Senior Member

Joined: 05/30/2011

View Profile


Offline
Posted: 09/04/20 01:06pm Link  |  Quote  |  Print  |  Notify Moderator

The pumps are inexpensive....so.....
Why not try the failing jack using a battery close to the motor? See if it responds better. Then go from there. Just jumper the wires. Grease up the legs first.

hotjag1

Lake Chelan, Wa/Lake Havasu, Az.

Senior Member

Joined: 07/14/2002

View Profile



Good Sam RV Club Member


Posted: 09/04/20 01:30pm Link  |  Quote  |  Print  |  Notify Moderator

I've accidently left our water pump running dry a couple of days at a time on several occasions and I've never had to replace a pump.


hotjag1
2003 40' Allegro Bus, 3 slides, 400hp 8.9 liter ISL Cummins

2000 24' Dynamax Isata


kohldad

Goose Creek, SC

Senior Member

Joined: 07/20/2004

View Profile



Good Sam RV Club Member

Offline
Posted: 09/04/20 01:35pm Link  |  Quote  |  Print  |  Notify Moderator

The pump is designed to run continuous and dry. No harm was done. My father has left his on about a month without water with no issues 5 years later.

For the motor my guess would be it is the one with either the most weight or the one with the most wiring between it and the battery. Either will make it run slightly lower. A good way to test is compare it's run time over 6" of unloaded travel as there shouldn't be much time difference between the jacks. You may want to take the time to service the gears as they do need to be greased once in a while. I wouldn't worry about it be a little slower but would if it requires twice the run time.


2015 Ram 3500 4x4 Crew Cab SRW 6.4 Hemi LB 3.73 (12.4 hand calc avg mpg after 92,000 miles with camper)
2004 Lance 815 (prev: 2004 FW 35'; 1994 TT 30'; Tents)


joelc

Cedar Point, NC

Senior Member

Joined: 02/23/2004

View Profile


Offline
Posted: 09/04/20 05:30pm Link  |  Quote  |  Print  |  Notify Moderator

1. Pumps should have an overheat shut off. My question is if it was primed where was the water going. They are supposed to shut off automatically wen demand ceases. If they keep running with no demand you might have a leak somewhere.
2. I have a Big Foot system and one of my jacks is also slower than the other. I have had no issues.

Sjm9911

New Jersey

Senior Member

Joined: 07/01/2020

View Profile



Good Sam RV Club Member

Offline
Posted: 09/04/20 05:35pm Link  |  Quote  |  Print  |  Notify Moderator

What he said on the pump. They run up untill pressure builds up then shut off. If it was costently running, look for a leak or check the pump check valve. Pump should be ok, but find why it didnt shut off.


2012 kz spree 220 ks
2020 Silverado 2500
Equalizer ( because i have it)
Formerly a pup owner.

prginocx

Portland, OR.

New Member

Joined: 01/12/2006

View Profile


Offline
Posted: 09/04/20 05:48pm Link  |  Quote  |  Print  |  Notify Moderator

I found a small ddrip in the shower, the wand was ON, but the wand has a shutoff nub on it, so tiny drip. Turned the wand OFF, now pump stops. I guess I"m good to go on the pump.

The slower jack is farther from the battery for sure. How do I lube the gears ? remove the cover and it will be obvious ?

Reply to Topic  |  Subscribe  |  Print Topic  |  Post New Topic  | 

Open Roads Forum  >  Truck Campers

 > Question about my on-demand water pump and ?
Search:   Advanced Search

Search only in Truck Campers


New posts No new posts
Closed, new posts Closed, no new posts
Moved, new posts Moved, no new posts

Adjust text size:




© 2021 CWI, Inc. © 2021 Good Sam Enterprises, LLC. All Rights Reserved.