Good Sam Club Open Roads Forum: Tech Issues: Backup camera has no power
Open Roads Forum Already a member? Login here.   If not, Register Today!  |  Help

Newest  |  Active  |  Popular  |  RVing FAQ Forum Rules  |  Forum Posting Help and Support  |  Contact  

Search:   Advanced Search

Search only in Tech Issues

Open Roads Forum  >  Tech Issues

 > Backup camera has no power

Reply to Topic  |  Subscribe  |  Print Topic  |  Post New Topic  | 
Page of 2  
Next
DunnInn

Texas

Full Member

Joined: 01/17/2012

View Profile



Good Sam RV Club Member

Offline
Posted: 09/05/20 06:50pm Link  |  Quote  |  Print  |  Notify Moderator

After lots of testing, we've determined there is no power to our backup camera. It looks like the previous owner replaced the original monitor with a Kenwood GPS model radio and also replaced the original backup camera. Our guess is that this was done by a audio shop. Soooo, anybody have any opinions on where we should take the rv to have this repaired? An RV shop or an audio store? Thanks.

Seon

Lake Camanche, CA

Senior Member

Joined: 07/02/2006

View Profile


Offline
Posted: 09/05/20 08:04pm Link  |  Quote  |  Print  |  Notify Moderator

I'd go to audio shop.

My nephew works in an audio shop that works exclusively installing gps, audio, alarms, etc on new and used car dealerships as well as on friends and family's car's systems and can pin point the problem right away.

corvettekent

Marysville, WA

Senior Member

Joined: 09/21/2014

View Profile



Good Sam RV Club Member

Offline
Posted: 09/05/20 08:34pm Link  |  Quote  |  Print  |  Notify Moderator

The back up camera should only have power when the RV is in reverse.


2007.5 GMC Dually EC/LB, LMM. Banks IQ, Speed Brake, Six Gun. B&W Turnover Ball, Companion Hitch, Amp power steps. Hadley Air horns.

2004 32' Carriage 5th wheel. 860 watts of solar MPPT and four 6 volt batteries. Samlex 2,000 watt Pure Sine Wave Inverter.


Sjm9911

New Jersey

Senior Member

Joined: 07/01/2020

View Profile



Good Sam RV Club Member

Offline
Posted: 09/05/20 09:37pm Link  |  Quote  |  Print  |  Notify Moderator

Or it could be wired into the running lights.


2012 kz spree 220 ks
2020 Silverado 2500
Equalizer ( because i have it)
Formerly a pup owner.

DunnInn

Texas

Full Member

Joined: 01/17/2012

View Profile



Good Sam RV Club Member

Offline
Posted: 09/06/20 06:09am Link  |  Quote  |  Print  |  Notify Moderator

We have a rocker switch on the front panel that lets us turn on the camera whenever we want. We've checked the power coming from the switch and it has power from there, also has power in the front running to the back, so SOMEWHERE between the front and the back, it's broken, unplugged, etc. It's a 41 foot Newmar Dutch Star, and 41 feet is a lot to try to fish wires through.

Bill/Diana

Southeastern Pennsylvania

Senior Member

Joined: 04/25/2002

View Profile



Good Sam RV Club Member


Posted: 09/06/20 03:00pm Link  |  Quote  |  Print  |  Notify Moderator

Have you called the previous owner for some help?


Bill & Diana

Please click here to visit our Website


DunnInn

Texas

Full Member

Joined: 01/17/2012

View Profile



Good Sam RV Club Member

Offline
Posted: 09/06/20 03:01pm Link  |  Quote  |  Print  |  Notify Moderator

Haven't contacted the previous owner. We've had the coach since 2013 and didn't have any contact info for them, unfortunately.

Bill/Diana

Southeastern Pennsylvania

Senior Member

Joined: 04/25/2002

View Profile



Good Sam RV Club Member


Posted: 09/06/20 03:11pm Link  |  Quote  |  Print  |  Notify Moderator

Do you have an owners manual for the backup system? What make & model is the system?

Bill/Diana

Southeastern Pennsylvania

Senior Member

Joined: 04/25/2002

View Profile



Good Sam RV Club Member


Posted: 09/06/20 03:18pm Link  |  Quote  |  Print  |  Notify Moderator

corvettekent wrote:

The back up camera should only have power when the RV is in reverse.


Just an FYI. This is not necessarily correct. Some can be wired to always be on, not just in reverse. In fact, mine is wired so the monitor comes on automatically when I start the engine. 95% of the time I leave the monitor on to serve as my rear view mirror while driving down the highway.

DunnInn

Texas

Full Member

Joined: 01/17/2012

View Profile



Good Sam RV Club Member

Offline
Posted: 09/06/20 03:21pm Link  |  Quote  |  Print  |  Notify Moderator

Camera is a Power Acoustik. It's hooked into a Kenwood GPS/radio/video system. We THINK the previous owner had the original monitor and radio replaced with the Kenwood unit and they also put in a new camera. They probably just did the quickest thing they could to hook it up. Unfortunately, that leaves us in the dark - literally. It's been working for the last 7 years and suddenly quits. REALLY thought it was just the camera, but after a lot of testing, we're seeing that the camera isn't getting any power to it even though there seems to be power running from the front of the rv.

Reply to Topic  |  Subscribe  |  Print Topic  |  Post New Topic  | 
Page of 2  
Next

Open Roads Forum  >  Tech Issues

 > Backup camera has no power
Search:   Advanced Search

Search only in Tech Issues


New posts No new posts
Closed, new posts Closed, no new posts
Moved, new posts Moved, no new posts

Adjust text size:




© 2020 CWI, Inc. © 2020 Good Sam Enterprises, LLC. All Rights Reserved.