Good Sam Club Open Roads Forum: Tech Issues: Refridgerator is acting bizarre
Open Roads Forum Already a member? Login here.   If not, Register Today!  |  Help

Newest  |  Active  |  Popular  |  RVing FAQ Forum Rules  |  Forum Posting Help and Support  |  Contact  

Search:   Advanced Search

Search only in Tech Issues

Open Roads Forum  >  Tech Issues

 > Refridgerator is acting bizarre

Reply to Topic  |  Subscribe  |  Print Topic  |  Post New Topic  | 
Page of 3  
Prev
randompanda

Kansas City, MO

New Member

Joined: 04/10/2013

View Profile


Offline
Posted: 11/30/20 04:03pm Link  |  Quote  |  Print  |  Notify Moderator

I'm in the same place I was the last 2 winters and never had this problem. I've had this rv 4 years and even in Colorado in worse cold weather so something broke recently. I'd like to replace the part. Thank everyone for trying [emoticon]

Old-Biscuit

Verde Valley

Senior Member

Joined: 06/20/2009

View Profile



Posted: 11/30/20 05:24pm Link  |  Quote  |  Print  |  Notify Moderator

Cold temps would NOT shut fridge off...as in loss of power/turning off
Causing 'Check" Light to come on etc

Cold temps will cause lack of cooling due to coolant not flowing

The Light bulb in outside compartment will help with coolant flow but will not fix a circuit board that is acting up


Is it time for your medication or mine?


2007 DODGE 3500 QC SRW 5.9L CTD In-Bed 'quiet gen'
2007 HitchHiker II 32.5 UKTG 2000W Xantex Inverter
On the Road Debt Free April '07
Off the road still Debt Free Jan. '14

MitchF150

Puyallup, WA

Senior Member

Joined: 07/13/2002

View Profile


Offline
Posted: 11/30/20 06:42pm Link  |  Quote  |  Print  |  Notify Moderator

Yeah.. I still say the board.. Mine would work fine when on 12v only. Plug into 120v and it would work fine until it needed to cycle. Then, it would shut off and throw the check light.

I have more problems with cooling my fridge when it's HOT outside. I have my fridge in a slide, so it needs an upper vent to expel the heat.. Since heat rises and does not like to go sideways, I have to provide additional fans to push that heat out the side..

Anyway, the board only costs $100 give or take and solved my problem.. And even it does not solve yours.... Well, you have a backup board for when it does fail..

I know, not your cut and dry answer to your problem, but that's all I got for ya.. [emoticon]

Good luck! Mitch


2013 F150 XLT 4x4 SuperCab Max Tow Egoboost 3.73 gears #7700 GVWR #1920 payload. 2019 Rockwood Mini Lite 2511S.

BobsYourUncle

Calgary Alberta Canada

Senior Member

Joined: 12/12/2003

View Profile


Offline
Posted: 11/30/20 06:54pm Link  |  Quote  |  Print  |  Notify Moderator

MitchF150 wrote:


Anyway, the board only costs $100 give or take and solved my problem..

You were lucky Mitch, I was on the road, on Vancouver Island when my fridge packed it in. The local stealership hosed me $250. for a new Dinosaur board.
Not much I could do, my fridge full of food was getting warm fast.

Similar symptoms to the OP, but my check light finally came on and stayed on. Mine too was an RM2652, same fridge.


2007 GMC 3500 dually ext. cab 4X4 LBZ
Dmax/Allison

2007 Pacific Coachworks Tango 306RLSS - 32'


MitchF150

Puyallup, WA

Senior Member

Joined: 07/13/2002

View Profile


Offline
Posted: 11/30/20 07:32pm Link  |  Quote  |  Print  |  Notify Moderator

Yeah, sucks when out on the road Bob.. Kinda between a rock and a hard place there... But, you gotta do what you gotta do.

I was lucky, in that my rig was still at home and I was testing out the systems before it's first trip. I had a couple of weeks to do that, so took advantage of it.

Once I figured out it only happened when plugged into 120v regardless of running on LP or electric and I googled that, it all pointed to the board.

I don't know if this is the 'dinosaur' board, but it was my exact model number for the Dometic fridge involved here..

https://smile.amazon.com/gp/product/B00B........_yo_dt_b_search_asin_title?ie=UTF8&psc=1

My old 2003 Prowler was the same Dometic model and I never had any issues with it.. My 2019 failed the first day! ha, ha...

Anyway, figured it out and didn't dick around with the dealer on it for a lousy $100 and not looking back.

Mitch

BobsYourUncle

Calgary Alberta Canada

Senior Member

Joined: 12/12/2003

View Profile


Offline
Posted: 11/30/20 09:32pm Link  |  Quote  |  Print  |  Notify Moderator

Yeah Mitch, I'd have done the same thing.
Hundred bucks, done! Good decision.
And its always nice when you troubleshoot things and figure out the problem correctly.
And even better when your rig is still at home.

MitchF150

Puyallup, WA

Senior Member

Joined: 07/13/2002

View Profile


Offline
Posted: 11/30/20 10:14pm Link  |  Quote  |  Print  |  Notify Moderator

Quote:

And even better when your rig is still at home.


That's always the best luck! Thanks Bob! Mitch

randompanda

Kansas City, MO

New Member

Joined: 04/10/2013

View Profile


Offline
Posted: 12/04/20 11:07am Link  |  Quote  |  Print  |  Notify Moderator

In case someone else has this problem I wanted to put the solution. We purchased a 2nd thermistor and now it's running fine, which means the 1st thermistor we bought was faulty.

wopachop

Who run bartertown

Senior Member

Joined: 11/17/2006

View Profile


Offline
Posted: 12/04/20 11:12am Link  |  Quote  |  Print  |  Notify Moderator

Test the ohms to confirm?

randompanda

Kansas City, MO

New Member

Joined: 04/10/2013

View Profile


Offline
Posted: 12/12/20 04:03pm Link  |  Quote  |  Print  |  Notify Moderator

You're right lol we should've checked.
We replaced the circuit board and now we have no power at all. no lights . nothing

Reply to Topic  |  Subscribe  |  Print Topic  |  Post New Topic  | 
Page of 3  
Prev

Open Roads Forum  >  Tech Issues

 > Refridgerator is acting bizarre
Search:   Advanced Search

Search only in Tech Issues


New posts No new posts
Closed, new posts Closed, no new posts
Moved, new posts Moved, no new posts

Adjust text size:




© 2021 CWI, Inc. © 2021 Good Sam Enterprises, LLC. All Rights Reserved.