Good Sam Club Open Roads Forum: Class A Motorhomes: 2004 winnebago adventurer
Open Roads Forum Already a member? Login here.   If not, Register Today!  |  Help

Newest  |  Active  |  Popular  |  RVing FAQ Forum Rules  |  Forum Posting Help and Support  |  Contact  

Search:   Advanced Search

Search only in Class A Motorhomes

Open Roads Forum  >  Class A Motorhomes  >  Maintenance Issues & Tips

 > 2004 winnebago adventurer

Reply to Topic  |  Subscribe  |  Print Topic  |  Post New Topic  | 
murphy8

home

New Member

Joined: 08/22/2014

View Profile



Good Sam RV Club Member

Offline
Posted: 11/30/20 04:59pm Link  |  Quote  |  Print  |  Notify Moderator

2004 winn adventurer
workhorse chassis 8.1 vortex
when under 30 degrees transmission wont shift starts out in 2nd gear i believe. if i drive a mile or 2 shut it off and restart it shifts fine. this always does it when cold,then i can drive all the way to florida with no problems. ive had rv for 8 years .but im leaving later this winter when its sub zero. im afraid it wont warm up enough.
any clues thankyou

midnightsadie

ohio

Senior Member

Joined: 01/07/2008

View Profile


Offline
Posted: 11/30/20 05:24pm Link  |  Quote  |  Print  |  Notify Moderator

might change the tranny fliud.

murphy8

home

New Member

Joined: 08/22/2014

View Profile



Good Sam RV Club Member

Offline
Posted: 11/30/20 05:33pm Link  |  Quote  |  Print  |  Notify Moderator

i did still does it

Lwiddis

near Bishop, California

Senior Member

Joined: 08/12/2016

View Profile



Good Sam RV Club Member

Offline
Posted: 11/30/20 06:01pm Link  |  Quote  |  Print  |  Notify Moderator

After 21 years of service, seems time for pro to examine your transmission.


Winnebago 2101DS TT & 2020 Chevy Silverado 1500 LTZ Z71, 300 watt solar-parallel & MPPT, Trojan T-125s. TALL flag pole. Prefer USFS, COE, BLM, NPS, TVA, state & county camps. Bicyclist! 14 year Army vet-11B40 then 11A - (MOS 1542 & 1560) IOBC & IOAC grad


K Charles

Connecticut

Senior Member

Joined: 03/06/2010

View Profile



Good Sam RV Club Member

Offline
Posted: 11/30/20 06:06pm Link  |  Quote  |  Print  |  Notify Moderator

What code did it set?

* This post was edited 11/30/20 07:01pm by K Charles *





ArchHoagland

Clovis, CA, USA

Senior Member

Joined: 11/28/2004

View Profile



Good Sam RV Club Member

Offline
Posted: 11/30/20 09:06pm Link  |  Quote  |  Print  |  Notify Moderator

How long has it been doing this?


2004 Monaco La Palma 36DBD
Workhorse W22 8.1 Gas Allison 1000, 7.1 mpg

2000 LEXUS RX300 FWD 22MPG 4020 LBS
US Gear Brakes


allbrandauto

maryland

Senior Member

Joined: 09/19/2013

View Profile



Good Sam RV Club Member

Offline
Posted: 12/01/20 06:25am Link  |  Quote  |  Print  |  Notify Moderator

2nd gear is a default mode you have a electrical problem maybe a shift soliniod maybe the trans. control module you need someone that has a scanner most automobile repair shops will have a scanner that has workhorse software

murphy8

home

New Member

Joined: 08/22/2014

View Profile



Good Sam RV Club Member

Offline
Posted: 12/01/20 08:45am Link  |  Quote  |  Print  |  Notify Moderator

Thanks that helps..

allbrandauto

maryland

Senior Member

Joined: 09/19/2013

View Profile



Good Sam RV Club Member

Offline
Posted: 12/01/20 09:01am Link  |  Quote  |  Print  |  Notify Moderator

you can email me at [email protected] .com I can walk you through your problem

Reply to Topic  |  Subscribe  |  Print Topic  |  Post New Topic  | 

Open Roads Forum  >  Class A Motorhomes  >  Maintenance Issues & Tips

 > 2004 winnebago adventurer
Search:   Advanced Search

Search only in Class A Motorhomes


New posts No new posts
Closed, new posts Closed, no new posts
Moved, new posts Moved, no new posts

Adjust text size:




© 2021 CWI, Inc. © 2021 Good Sam Enterprises, LLC. All Rights Reserved.