Good Sam Club Open Roads Forum: What Did I Do to Break My Generators???
Open Roads Forum Already a member? Login here.   If not, Register Today!  |  Help

Newest  |  Active  |  Popular  |  RVing FAQ Forum Rules  |  Forum Posting Help and Support  |  Contact  

Search:   Advanced Search

Search only in Tech Issues

Open Roads Forum  >  Tech Issues

 > What Did I Do to Break My Generators???

Reply to Topic  |  Subscribe  |  Print Topic  |  Post New Topic  | 
Page of 3  
Next
HadEnough

Traveling. Always.

Senior Member

Joined: 04/17/2016

View Profile


Offline
Posted: 02/12/21 03:42pm Link  |  Quote  |  Print  |  Notify Moderator

I’m at a complete loss. I broke BOTH of my generators doing something very simple.

I currently have 3 (qty) 2400 watt Nothstar Generators. They have always run like a Swiss watch for me over the years. I have owned 2 others before these over the decades.

I currently need 3 because I’m off grid and have a living area and a workshop area to air condition.

Meet the generators:

Generator 1: bought 2 years ago. Ran for thousands of hours trouble free. Ran any time it was above 85F in Florida. Hard to even imagine how well this generator performed for a gasoline portable. Recently, the AVR (automatic voltage regulator) went bad delivering 90V instead of its normal 120.

Generator 2: Bought 6 weeks ago. in the work area running like a Swiss watch.

Generator 3: Bought 6 weeks ago. Carb started spraying fuel out the top after about 4 hours of use.

What I did:

I put generator 1 and generator 3 next to each other and set them on their ends so the power heads were sticking up in the air. Oil cane out the breather tubes. Whoops.

I then took off the face plate from the generator heads, took out the AVRs and swapped them.

Now neither generator will turn!!!

I cannot pull the pull start. It’s jammed!!

I can turn the generator in the opposite direction from normal rotation. I can even pull the pull start to turn it back to where it is jammed. But I can’t pass the jammed area in the rotation.

My mind is BLOWN.

I definitely caused this problem, but all I did was stand the generators on end and swap the AVRs. Then close them back up to test.

How on Earth can swapping AVRs on an identical pair of generators cause both of them to lock up at a certain point in their rotation, but still be able to turn backwards???

My head hurts. Can’t find the logic here.

gatorcq

Arizona

Senior Member

Joined: 03/15/2004

View Profile





Offline
Posted: 02/12/21 03:45pm Link  |  Quote  |  Print  |  Notify Moderator

Forget logic So, when are you just start and disassemble one of them?


Dale & Susan
DaGirls II Rv - Dakota & Tilly Traveling Companions.
2008 Alfa Gold, 2015 Ford F150 XLT
Roadmaster and Air Brake System
1600 Watts, Magnum Inv/Chg&Solar
800 Lithium Battery
DaGirslRV Blog

Krusty

Calgary, Alberta,Canada

Senior Member

Joined: 04/26/2003

View Profile


Offline
Posted: 02/12/21 03:54pm Link  |  Quote  |  Print  |  Notify Moderator

Combustion chamber full of oil now? Pull a sparkplug and see if it will turn


Krusty
92 F-250 4x4 460 5spd 4.10LS Prodigy
97 Rustler RT190
EU2000i
Garmin

HadEnough

Traveling. Always.

Senior Member

Joined: 04/17/2016

View Profile


Offline
Posted: 02/12/21 03:57pm Link  |  Quote  |  Print  |  Notify Moderator

Krusty wrote:

Combustion chamber full of oil now? Pull a sparkplug and see if it will turn


Holy ****. That’s probably a good possibility. I’ll have a look now.

Homeless by Choice

North America

Senior Member

Joined: 09/09/2012

View Profile



Good Sam RV Club Member

Offline
Posted: 02/12/21 04:01pm Link  |  Quote  |  Print  |  Notify Moderator

Could something dropped off when you disassembled the AVR? How far can you turn the crankshaft backwards? More than one full revolution? Do they both get stuck at about the same position?

My guess is that something (nut, bolt, bracket, tie down wire, etc) is jammed in the stator or flywheel area that allows it to only rotate so far?

LeRoy


Homeless by Choice
FULL TIMER since 2012
2015 Chevy 3500, Duramax, 4X4, DRW, Crew cab, Long bed
2013 Northern Lite 8'11"Q Sportsman truck camper
2015 Polaris RZR Side by Side

Darryl&Rita

Grande Prairie, Alberta

Senior Member

Joined: 03/15/2006

View Profile


Offline
Posted: 02/12/21 04:19pm Link  |  Quote  |  Print  |  Notify Moderator

Pull out the spark plugs on both machines. You hydro-locked them with oil. Pull the recoil cord to get as much as possible out. Replace the plugs, start them up. Expect lots of smoke, as the oil burns off. Expect to replace the plugs with new ones, after the smoke quits.


***UPDATE 2006 3500 SRW MegaCab pulling a 2007 fleetwood 5'er

BFL13

Victoria, BC

Senior Member

Joined: 02/15/2006

View Profile



Posted: 02/12/21 04:33pm Link  |  Quote  |  Print  |  Notify Moderator

I had to replace the pull start end of a small gen, and found it worked by the action of a plastic part ISTR called a "pall"???? anyway it was on a spring and stuck out to catch the next part in that turned whatever, can't remember the names of the parts. the plastic part can break and jam so you can't do the pull but the pall doesn't catch turning the other way where its rounded part hits first.

Sorry for the mangled description. [emoticon]


1. 1991 Oakland 28DB Class C
on Ford E350-460-7.5 Gas EFI
Photo in Profile
2. 1991 Bighorn 9.5ft Truck Camper on 2003 Chev 2500HD 6.0 Gas
See Profile for Electronic set-ups for 1. and 2.

HadEnough

Traveling. Always.

Senior Member

Joined: 04/17/2016

View Profile


Offline
Posted: 02/12/21 04:41pm Link  |  Quote  |  Print  |  Notify Moderator

Krusty wrote:

Combustion chamber full of oil now? Pull a sparkplug and see if it will turn



Solved!!

You’re a genius.

Got the oil out of the cylinder and trying to burn it off so the thing runs right again.

It’s putting out a nice 120v when it’s not sputtering.

HadEnough

Traveling. Always.

Senior Member

Joined: 04/17/2016

View Profile


Offline
Posted: 02/12/21 04:42pm Link  |  Quote  |  Print  |  Notify Moderator

Darryl&Rita wrote:

Pull out the spark plugs on both machines. You hydro-locked them with oil. Pull the recoil cord to get as much as possible out. Replace the plugs, start them up. Expect lots of smoke, as the oil burns off. Expect to replace the plugs with new ones, after the smoke quits.


Also a genius.

That’s exactly what it was. Burning off the oil right now.

MFL

Midwest

Senior Member

Joined: 11/28/2012

View Profile



Good Sam RV Club Member

Offline
Posted: 02/12/21 04:48pm Link  |  Quote  |  Print  |  Notify Moderator

HadEnough wrote:

Krusty wrote:

Combustion chamber full of oil now? Pull a sparkplug and see if it will turn



Solved!!

You’re a genius.

Got the oil out of the cylinder and trying to burn it off so the thing runs right again.

It’s putting out a nice 120v when it’s not sputtering.


Glad it is solved! Mine was run at factory, but shipped with no oil, and this is likely the reason they get shipped that way.

Jerry





Reply to Topic  |  Subscribe  |  Print Topic  |  Post New Topic  | 
Page of 3  
Next

Open Roads Forum  >  Tech Issues

 > What Did I Do to Break My Generators???
Search:   Advanced Search

Search only in Tech Issues


New posts No new posts
Closed, new posts Closed, no new posts
Moved, new posts Moved, no new posts

Adjust text size:




© 2021 CWI, Inc. © 2021 Good Sam Enterprises, LLC. All Rights Reserved.