Good Sam Club Open Roads Forum: Class C Motorhomes: Backup Camera
Open Roads Forum Already a member? Login here.   If not, Register Today!  |  Help

Newest  |  Active  |  Popular  |  RVing FAQ Forum Rules  |  Forum Posting Help and Support  |  Contact  

Search:   Advanced Search

Search only in Class C Motorhomes

Open Roads Forum  >  Class C Motorhomes  >  Class C

 > Backup Camera

Reply to Topic  |  Subscribe  |  Print Topic  |  Post New Topic  | 
Dooitslo

Nevada

New Member

Joined: 03/11/2021

View Profile



Good Sam RV Club Member

Offline
Posted: 03/11/21 02:26am Link  |  Quote  |  Print  |  Notify Moderator

I have a 2014 Jayco Greyhawk and experienced a recent electrical issue. I am appealing to anyone that can help because I'm not ready to pay $145.00 hr labor to tell me something that is simple to fix. We set up camp and used auto leveler with no issue. When we prepared to leave the levelers would not work, control panel would not light up. I contacted Bigfoot and the tech told me to check the solenoid behind the house battery rack. A 10 amp fuse was blown. First fuse I replaced blew right away, the second made it possible to raise the jacks. We did notice however that the backup camera monitor/radio was out. It rained quite a bit the day prior to living the RV park.IS IT POSSIBLE THAT THE BACKUP CAMERA SHORTED OUT DUE TO THE RAIN AND IT AFFECTED THE AUTO LEVELER SYSTEM? IF SO, CAN I JUST DISCONNECT THE BACKUP CAMERA AND JUST USE THE THE RADIO? ANY ADVICE WILL BE GREATLY APPRECIATED.

PartyOf Five

Wheaton, IL

Senior Member

Joined: 07/18/2016

View Profile



Good Sam RV Club Member

Offline
Posted: 03/11/21 10:21am Link  |  Quote  |  Print  |  Notify Moderator

You need to tell us what the 2 fuses you changed were for, besides the levels and camera. It's unlikely that an external backup camera took in water to the point of blowing a fuse. Possible but not likely the cause- I'd focus my energy elsewhere.

Also try a mobile rv mechanic. I use and post reviews at http://www.rvservicereviews.com/


PartyOf5 appreciating our Creator thru the creation. 5 yrs, 50k

May you find Peace in all you endeavor.

klutchdust

Orange, California

Senior Member

Joined: 06/09/2004

View Profile



Posted: 03/11/21 10:30am Link  |  Quote  |  Print  |  Notify Moderator

Seems unlikely that the camera and the leveling system would be on one 10 amp fuse. IF it were me I would investigate the camera. Is there a cover to remove, can you disconnect the wiring at the camera

and then put in a fuse to see if it blows. Shorts can be troublesome, you need to start at what you think may be the source. It sounds like water is the issue.

Reply to Topic  |  Subscribe  |  Print Topic  |  Post New Topic  | 

Open Roads Forum  >  Class C Motorhomes  >  Class C

 > Backup Camera
Search:   Advanced Search

Search only in Class C Motorhomes


New posts No new posts
Closed, new posts Closed, no new posts
Moved, new posts Moved, no new posts

Adjust text size:




© 2021 CWI, Inc. © 2021 Good Sam Enterprises, LLC. All Rights Reserved.