Good Sam Club Open Roads Forum: Class A Motorhomes: Water Pump Issue
Open Roads Forum Already a member? Login here.   If not, Register Today!  |  Help

Newest  |  Active  |  Popular  |  RVing FAQ Forum Rules  |  Forum Posting Help and Support  |  Contact  

Search:   Advanced Search

Search only in Class A Motorhomes

Open Roads Forum  >  Class A Motorhomes  >  All

 > Water Pump Issue

Reply to Topic  |  Subscribe  |  Print Topic  |  Post New Topic  | 
Branson N Tucson

Tn

Full Member

Joined: 05/09/2012

View Profile



Good Sam RV Club Member

Offline
Posted: 03/18/21 03:24pm Link  |  Quote  |  Print  |  Notify Moderator

I have a Sur Flow Water Pump.
All of a sudden when not hooked up to city water it is pushing the water out of were the city water connector is thus not getting any water out of the inside faucets inside.The
Pump is running. Any comments would be appreciated .

StarkNaked

West Seattle, WA

Senior Member

Joined: 09/13/2006

View Profile


Offline
Posted: 03/18/21 03:49pm Link  |  Quote  |  Print  |  Notify Moderator

Your check valve has failed, or is stuck. It could be as simple as re-seating the check valve.

Here are the instructions to fix.

https://www.sunlineclub.com/forums/f71/fresh-water-inlet-valve-repair-11736.html

Helpful hint: Never push the check valve in when the systems is pressurized, even just a little bit of water pressure.

If you can't fix right away, all you need is a male garden hose plug. Just screw it in where you would put your hose and it will seal the pressure.

LouLawrence

Traveling the US!

Full Member

Joined: 03/16/2021

View Profile



Posted: 03/18/21 04:35pm Link  |  Quote  |  Print  |  Notify Moderator

If you have a valve that needs to be turned to select city water, internal water or winterize, this valve may have failed or be turned to the wrong setting.

Old-Biscuit

Verde Valley

Senior Member

Joined: 06/20/2009

View Profile



Posted: 03/18/21 07:15pm Link  |  Quote  |  Print  |  Notify Moderator

StarkNaked wrote:

Your check valve has failed, or is stuck. It could be as simple as re-seating the check valve.

Here are the instructions to fix.

https://www.sunlineclub.com/forums/f71/fresh-water-inlet-valve-repair-11736.html

Helpful hint: Never push the check valve in when the systems is pressurized, even just a little bit of water pressure.

If you can't fix right away, all you need is a male garden hose plug. Just screw it in where you would put your hose and it will seal the pressure.


That is your problem and resolution
If the O-ring on the check valve plunger has become dislodged...replacement needed to fix it
OR install a brass garden hose shut off and forget about it
**Closed when using pump----Opened when connecting to city water via hose


Is it time for your medication or mine?


2007 DODGE 3500 QC SRW 5.9L CTD In-Bed 'quiet gen'
2007 HitchHiker II 32.5 UKTG 2000W Xantex Inverter
US NAVY------USS Decatur DDG31

ScottG

Bothell Wa.

Senior Member

Joined: 02/25/2005

View Profile



Posted: 03/18/21 08:19pm Link  |  Quote  |  Print  |  Notify Moderator

Good advice above. Main thing to note is there's nothing wrong with your water pump.

wa8yxm

Davison Michigan (East of Flint)

Senior Member

Joined: 07/04/2006

View Profile


Offline
Posted: 03/19/21 04:35am Link  |  Quote  |  Print  |  Notify Moderator

That is not a water pump problem it is a city inlet propblem

Several solutions
one replacing the city inlet is not all that hard
Two try removing the inlet screen washer and inside you will see a plastic "Button" with the pump on (NOTE YOU WILL GET WET) try pressing and releasing this button a couple times with something like a pencil eraser.

Some folks will holler 'You will break it' I do not know if that's true but since it's already broke.... what you got to lose?

Or you can get a quarter turn hose end valve and screw it into the port closed. Might just work (or not)

But Replacing the inlet is fairly easy.


Home was where I park it. but alas the.
2005 Damon Intruder 377 Alas declared a total loss
after a semi "nicked" it. Still have the radios
Kenwood TS-2000, ICOM ID-5100, ID-51A+2, ID-880 REF030C most times


Old-Biscuit

Verde Valley

Senior Member

Joined: 06/20/2009

View Profile



Posted: 03/19/21 11:57am Link  |  Quote  |  Print  |  Notify Moderator

wa8yxm wrote:

That is not a water pump problem it is a city inlet propblem

Several solutions
one replacing the city inlet is not all that hard
Two try removing the inlet screen washer and inside you will see a plastic "Button" with the pump on (NOTE YOU WILL GET WET) try pressing and releasing this button a couple times with something like a pencil eraser.

Some folks will holler 'You will break it' I do not know if that's true but since it's already broke.... what you got to lose?

Or you can get a quarter turn hose end valve and screw it into the port closed. Might just work (or not)

But Replacing the inlet is fairly easy.


Best to do W/O water supply ON and system pressure relieved (open a faucet)
Doing so WITH system Pressurized can dislodge the O-ring and making replacement necessary
Doing W/O system Pressurized could free up a stuck plunger and 'fix' it

Reply to Topic  |  Subscribe  |  Print Topic  |  Post New Topic  | 

Open Roads Forum  >  Class A Motorhomes  >  All

 > Water Pump Issue
Search:   Advanced Search

Search only in Class A Motorhomes


New posts No new posts
Closed, new posts Closed, no new posts
Moved, new posts Moved, no new posts

Adjust text size:




© 2021 CWI, Inc. © 2021 Good Sam Enterprises, LLC. All Rights Reserved.