Good Sam Club Open Roads Forum: Tech Issues: Multimeter Question
Open Roads Forum Already a member? Login here.   If not, Register Today!  |  Help

Newest  |  Active  |  Popular  |  RVing FAQ Forum Rules  |  Forum Posting Help and Support  |  Contact  

Search:   Advanced Search

Search only in Tech Issues

Open Roads Forum  >  Tech Issues

 > Multimeter Question

Reply to Topic  |  Subscribe  |  Print Topic  |  Post New Topic  | 
Page of 3  
Prev
pianotuna

Regina, SK, Canada

Senior Member

Joined: 12/18/2004

View Profile


Offline
Posted: 04/12/21 09:38pm Link  |  Quote  |  Print  |  Notify Moderator

Checking voltage under load may be a good plan.


Regards, Don
My ride is a 28 foot Class C, 256 watts solar, soon to have SiO2 batteries, 3000 watt Magnum hybrid inverter, Sola Basic Autoformer, Microair Easy Start.

YC 1

Yuba City Calif./ Auburndale Florida

Senior Member

Joined: 01/11/2005

View Profile



Good Sam RV Club Member

Offline
Posted: 04/13/21 03:55am Link  |  Quote  |  Print  |  Notify Moderator

Thermoguy wrote:

YC 1 wrote:

Have you tried to just pull the shoreline cord out a tiny bit and touch those lugs?


That wouldn't work and would be dangerous if it did...

You might be able to buy longer probes or similar - they are typically universal. There are other plug in meters but not sure if for 50Amp plug. The best bet is as everyone has suggested, get a surge protector.


Actually it does work, but you do need to be careful of course.
I tape my probes almost to the tip so they cannot short on anything nearby.

If the plug is pulled out slightly and still makes contact you can get a loaded circuit test versus an open circuit test. That is, can the post support your load.

Measuring voltages in this range is always hazardous and should be done with the utmost care. Standing in wet grass is not a good idea for example.


H/R Endeavor 2008
2013 Ford Edge toad
Full Timers


Gjac

Milford, CT

Senior Member

Joined: 08/16/2006

View Profile



Good Sam RV Club Member

Offline
Posted: 04/14/21 03:48pm Link  |  Quote  |  Print  |  Notify Moderator

I have an old yellow HF meter I bought 15 years ago and the cheap leads fell apart. I bought replacement leads from Radio Shack several years later. I don't stop at FHU CGs often but when I do I have never had a problem checking voltage. I never knew it was a problem until I read this thread.

Reply to Topic  |  Subscribe  |  Print Topic  |  Post New Topic  | 
Page of 3  
Prev

Open Roads Forum  >  Tech Issues

 > Multimeter Question
Search:   Advanced Search

Search only in Tech Issues


New posts No new posts
Closed, new posts Closed, no new posts
Moved, new posts Moved, no new posts

Adjust text size:




© 2021 CWI, Inc. © 2021 Good Sam Enterprises, LLC. All Rights Reserved.