Good Sam Club Open Roads Forum: water heater works fine - IF- I leave door open
Open Roads Forum Already a member? Login here.   If not, Register Today!  |  Help

Newest  |  Active  |  Popular  |  RVing FAQ Forum Rules  |  Forum Posting Help and Support  |  Contact  

Search:   Advanced Search

Search only in Tech Issues

Open Roads Forum  >  Tech Issues

 > water heater works fine - IF- I leave door open

Reply to Topic  |  Subscribe  |  Print Topic  |  Post New Topic  | 
Page of 4  
Next
Timeking

Florida USA

Full Member

Joined: 06/26/2010

View Profile



Good Sam RV Club Member

Offline
Posted: 05/08/21 01:34pm Link  |  Quote  |  Print  |  Notify Moderator

There are a lot of posts here about changing the control board, etc. But this has me stumped. Suburban SW6DEL.

If I leave the outside door closed, it will light, then go out, will not re-light, will not heat the water.

If I open the door, it will light, and heat the water up until hot then turn off (normal operation).

If I open the door, it will light, and run UNTIL I close the door, and it turns off.

WHAT?!?!?

enblethen

Moses Lake, WA

Senior Member

Joined: 01/05/2005

View Profile






Posted: 05/08/21 01:41pm Link  |  Quote  |  Print  |  Notify Moderator

Make sure wiring is clear of door
Check burner tube for bugs and or their nest.


Bud
USAF Retired
Pace Arrow

2003 Chev Ice Road Tracker


Old-Biscuit

Verde Valley

Senior Member

Joined: 06/20/2009

View Profile



Posted: 05/08/21 03:04pm Link  |  Quote  |  Print  |  Notify Moderator

Check that the High Voltage wiring (large Orange wire) is not being pitched when you close access panel....shorting to ground


Does the AC Element heat to temp with access panel closed?
*DEL uses DC to control AC & Gas


Is it time for your medication or mine?


2007 DODGE 3500 QC SRW 5.9L CTD In-Bed 'quiet gen'
2007 HitchHiker II 32.5 UKTG 2000W Xantex Inverter
US NAVY------USS Decatur DDG31

dougrainer

Carrolton, Texas

Senior Member

Joined: 06/11/2007

View Profile


Offline
Posted: 05/08/21 03:12pm Link  |  Quote  |  Print  |  Notify Moderator

Old-Biscuit wrote:

Check that the High Voltage wiring (large Orange wire) is not being pitched when you close access panel....shorting to ground


Does the AC Element heat to temp with access panel closed?
*DEL uses DC to control AC & Gas


The High Voltage wire when igniting puts out a hi voltage spark that will overcome a short to ground on the door. The RETURN millivolt signal for flame is NOT that strong and will be disrupted by a slight short to ground. So, do as he states. You can even use electrical tape to wrap the orange plug wire to stop the problem until you replace the Plug wire. Doug

PS. Pull the rubber boot off the electrode and make SURE the wire spade terminal is secured on the electrode spade. Closing the door may cause the gap if not secure to cause to lack of flame signal

* This post was edited 05/08/21 04:24pm by dougrainer *

wildtoad

Blythewood, SC

Senior Member

Joined: 06/05/2011

View Profile



Good Sam RV Club Member


Posted: 05/08/21 04:33pm Link  |  Quote  |  Print  |  Notify Moderator

Assuming this is on gas, sounds to me that there is an air flow issue thru the small air input port on the door. Door open plenty of air, door closed not so much.


Tom Wilds
Blythewood, SC
2016 Newmar Baystar Sport 3004
2015 Jeep Wrangler 2dr HT

rdhetrick

Texas

Senior Member

Joined: 08/30/2012

View Profile



Good Sam RV Club Member

Offline
Posted: 05/08/21 06:31pm Link  |  Quote  |  Print  |  Notify Moderator

My guess is the airflow mixture/regulator needs to be adjusted to get more airflow into the burner. Have you travelled to a higher elevation than you are normally at?


Rob
2006 Mandalay 40E Full Time
2015 Jeep Grand Cherokee

Lantley

Ellicott City, Maryland

Senior Member

Joined: 08/23/2005

View Profile


Online
Posted: 05/08/21 06:37pm Link  |  Quote  |  Print  |  Notify Moderator

Burner tube needs to be blown out with compressed air, bugs and dirt hinder the air flow and cause issues, common problem


19'Duramax w/hips,12'Open Range,Titan Disc Brake
BD3,RV safepower,22" Blackstone
Ox Bedsaver,RV760 w/BC20,Glow Steps, Enduraplas25,Pedego
BakFlip,RVLock,5500 Onan LP,Prog.50A surge,Hughes autoformer
Porta Bote 8.0 Nissan,Sailun S637
Correct Trax,Splendide


Old-Biscuit

Verde Valley

Senior Member

Joined: 06/20/2009

View Profile



Posted: 05/08/21 06:49pm Link  |  Quote  |  Print  |  Notify Moderator

As Doug explained...flame proving is being lost due to short to ground

Reposition Large Orange wire....tape it....make sure it isn't making contact

Then you should be able to close door and have LP System function as designed

profdant139

Southern California

Senior Member

Joined: 11/14/2005

View Profile


Offline
Posted: 05/08/21 07:34pm Link  |  Quote  |  Print  |  Notify Moderator

I have the same problem, but only over 9000 feet! I think it must be an airflow issue. It is solved when I open the outside door.


2012 Fun Finder X-139 "Boondock Style" (axle-flipped and extra insulation)
2013 Toyota Tacoma Off-Road (semi-beefy tires and components)
Our trips -- pix and text
About our trailer
"A journey of a thousand miles begins with a single list."


Old-Biscuit

Verde Valley

Senior Member

Joined: 06/20/2009

View Profile



Posted: 05/08/21 09:42pm Link  |  Quote  |  Print  |  Notify Moderator

profdant139 wrote:

I have the same problem, but only over 9000 feet! I think it must be an airflow issue. It is solved when I open the outside door.


Highest point in FL is the Skybridge

Reply to Topic  |  Subscribe  |  Print Topic  |  Post New Topic  | 
Page of 4  
Next

Open Roads Forum  >  Tech Issues

 > water heater works fine - IF- I leave door open
Search:   Advanced Search

Search only in Tech Issues


New posts No new posts
Closed, new posts Closed, no new posts
Moved, new posts Moved, no new posts

Adjust text size:




© 2021 CWI, Inc. © 2021 Good Sam Enterprises, LLC. All Rights Reserved.