Good Sam Club Open Roads Forum: Help! Onan 4K generator refuses to start and stay on
Open Roads Forum Already a member? Login here.   If not, Register Today!  |  Help

Newest  |  Active  |  Popular  |  RVing FAQ Forum Rules  |  Forum Posting Help and Support  |  Contact  

Search:   Advanced Search

Search only in Class C Motorhomes

Open Roads Forum  >  Class C Motorhomes  >  Class C

 > Help! Onan 4K generator refuses to start and stay on

Reply to Topic  |  Subscribe  |  Print Topic  |  Post New Topic  | 
Page of 4  
Next
Kennyg

Green bay, Wi 54303

Senior Member

Joined: 10/05/2004

View Profile


Offline
Posted: 05/14/21 08:22am Link  |  Quote  |  Print  |  Notify Moderator

Here I go again. Am at home now and I tried the generator again. It started, but only for about 15 seconds and then shut down. During this short time it ran rough and the exhaust blew constant blue smoke which I assume is excessive gas. As I stated before I did take the carb apart an soaked in cleaner and blwe air thru all the holes. So, where go I go from here?
Should I be replacing the carb or pull the carb entirely from generator and soak it in carb cleaner. Nothing seems to work.


Kennyg

pianotuna

Regina, SK, Canada

Senior Member

Joined: 12/18/2004

View Profile


Offline
Posted: 05/14/21 08:36am Link  |  Quote  |  Print  |  Notify Moderator

next time you get it fixed use only premium fuel and treat it with seafoam.

It would not hurt to try some seafoam right now.


Regards, Don
My ride is a 28 foot Class C, 256 watts solar, soon to have SiO2 batteries, 3000 watt Magnum hybrid inverter, Sola Basic Autoformer, Microair Easy Start.

enblethen

Moses Lake, WA

Senior Member

Joined: 01/05/2005

View Profile






Posted: 05/14/21 08:51am Link  |  Quote  |  Print  |  Notify Moderator

Blue smoke is not normally gas but oil.
Check your oil level, It may have too much
When was last time genset was run? Could be sticky valve.
When was oil changed last time?


Bud
USAF Retired
Pace Arrow

2003 Chev Ice Road Tracker


Grit dog

Black Diamond, WA

Senior Member

Joined: 05/06/2013

View Profile


Offline
Posted: 05/14/21 10:17am Link  |  Quote  |  Print  |  Notify Moderator

What he said ^.
Gasoline or LP? Presume gasoline.
Does it start and run 15 sec repeatedly or was it one and done?

Blue smoke is oil.
Not necessarily an issue. Could be from sitting, could be burning a little oil but still ok.
A lot of people don’t even notice, but most engines, new or old, in my experience, will blow a little blue smoke on startup. Once in a while. Could be a chunk of carbon holding a valve slightly open, sticky ring that frees itself up or any other number of things.

If it does it every time cold and then clears up, likely worn top end valves etc. if it smokes after warmed up and constantly then likely rings.

Is the crankcase over full ( gas draining into case, stuck float on a gravity fed, primer stuck on and you didn’t notice etc)? If so it could be sucking in diluted oil. Could also make it not run right, maybe.
From there, could be carb plugged up
Need more history and symptoms.
Old gas, sat for a long time?
Original question is it repeatable runs and dies?
If no restart, does it fire on ether?
Is the fuel pump working consistently? Did you check it?


2016 Ram 2500, MotorOps.ca EFIlive tuned, 5” turbo back, 6" lift on 37s
2017 Heartland Torque T29

fourthclassC

MA

Senior Member

Joined: 06/09/2005

View Profile



Good Sam RV Club Member

Offline
Posted: 05/14/21 10:32am Link  |  Quote  |  Print  |  Notify Moderator

While that 15 seconds run time seems short for this issue, all my Onan 4k watt gens. Required new fuel pumps. The known issue shows up as the engine runs for a while then quits. Just FYI. But that 15 secs. may be related to some other issue like you said on related to the carb. Depending on the year, the choke linkage has also caused me problems in the past.

bobndot

USA

Senior Member

Joined: 08/21/2007

View Profile


Offline
Posted: 05/14/21 10:36am Link  |  Quote  |  Print  |  Notify Moderator

If u are talking about a 2007 model Onan, it could be a lot of things at that age As said check oil level first. If you are in the habit of using the genny while off level that could possibly be an oil related internal problem over time. When was it last serviced by someone that knows the Onan ?

jyh818

Chino, CA

Senior Member

Joined: 08/29/2009

View Profile



Good Sam RV Club Member

Offline
Posted: 05/14/21 03:18pm Link  |  Quote  |  Print  |  Notify Moderator

Are you below 1/4 tank of gas in your RV. I think it prevents you from using the generator if your RV fuel tank is below 1/4 tank.


2002 Ford Excursion XLT 6.8L V-10 2WD, 4.30 Limited Slip
Rear Hellwig Sway Bar
2009 Skyline Nomad 260
Prodigy Brake Controller
EAZ-Lift WD Hitch


whemme

Spencer, IA

Senior Member

Joined: 08/26/2004

View Profile



Posted: 05/14/21 05:10pm Link  |  Quote  |  Print  |  Notify Moderator

jyh818 wrote:

Are you below 1/4 tank of gas in your RV. I think it prevents you from using the generator if your RV fuel tank is below 1/4 tank.

If that was true the generator would not even start and run for 15 seconds. Problem sounds to me that you may have a defective Onan fuel pump.


2002 Born Free 26' RSB Motorcoach
2005 Chevrolet Malibu LS Toad

jdc1

Rescue, Ca

Senior Member

Joined: 05/30/2011

View Profile


Offline
Posted: 05/14/21 08:12pm Link  |  Quote  |  Print  |  Notify Moderator

You can replace that Onan pump with a low psi off the shelf pump (under $30).

But, my money is on the float level.

ndrorder

Southwest

Senior Member

Joined: 05/09/2017

View Profile



Good Sam RV Club Member

Offline
Posted: 05/15/21 06:03am Link  |  Quote  |  Print  |  Notify Moderator

whemme wrote:

jyh818 wrote:

Are you below 1/4 tank of gas in your RV. I think it prevents you from using the generator if your RV fuel tank is below 1/4 tank.

If that was true the generator would not even start and run for 15 seconds. Problem sounds to me that you may have a defective Onan fuel pump.


Not exactly. There is about 15 seconds of runtime worth of fuel in the carb bowl when it is full. Without 1/4 tank or more or with a failed fuel pump, then the bowl wouldn't be replenished.


__________________________________________________
Cliff
2011 Four Winds Chateau 23U

Reply to Topic  |  Subscribe  |  Print Topic  |  Post New Topic  | 
Page of 4  
Next

Open Roads Forum  >  Class C Motorhomes  >  Class C

 > Help! Onan 4K generator refuses to start and stay on
Search:   Advanced Search

Search only in Class C Motorhomes


New posts No new posts
Closed, new posts Closed, no new posts
Moved, new posts Moved, no new posts

Adjust text size:




© 2021 CWI, Inc. © 2021 Good Sam Enterprises, LLC. All Rights Reserved.