Good Sam Club Open Roads Forum: Tech Issues: Thermostat woes
Open Roads Forum Already a member? Login here.   If not, Register Today!  |  Help

Newest  |  Active  |  Popular  |  RVing FAQ Forum Rules  |  Forum Posting Help and Support  |  Contact  

Search:   Advanced Search

Search only in Tech Issues

Open Roads Forum  >  Tech Issues

 > Thermostat woes

Reply to Topic  |  Subscribe  |  Print Topic  |  Post New Topic  | 
Hemling

Miami, FL

Full Member

Joined: 06/05/2016

View Profile


Offline
Posted: 07/15/21 07:49pm Link  |  Quote  |  Print  |  Notify Moderator

We have the Coleman 'Airxcel' thermostat in our Keystone Sprinter. It is the basic unit, one long rectangular button on the bottom for mode, and then two triangular buttons to go up or down on temperature. Long story short, it is cutting out randomly on us, which is really frustrating. Sometimes it will blank out completely, in which case tapping on or messing with the unit will usually get it to 'power' back on, and sometimes it just kicks off before reaching the set temperature, but the display still functions so you can just restart it. When we are all in the camper for a while it will sometimes run flawlessly all day, other times it will glitch out 2-3 times within a half hour. If we are gone all day, we always come back to a 100+ degree camper. I have very little confidence in the cheapness of this unit, so I would much rather replace it with a wired, programmable one. What options are there that will still utilize the stock wiring? It's got red blue green white and yellow wires going into it.

Hemling

Miami, FL

Full Member

Joined: 06/05/2016

View Profile


Offline
Posted: 07/15/21 08:21pm Link  |  Quote  |  Print  |  Notify Moderator

Sorry - correction - there are actually six wires going into the back of the unit. Also, there is a brown wire that comes out of the wire packet from the wall, but has been snipped off and does not go into the thermostat at all. The diagram on the back of the unit seems to indicate that there is a blank spot corresponding to this wire's location. Maybe an unused wire for other models? I am sitting in the camper right now and it kicked off a few minutes ago, so I took it off the wall, manhandled it a bit, and it's back to working now, but the digital display is off. Jumped 5 degrees when I took it off the wall. Any help in getting a programmable unit installed is appreciated. I'm fine with electrical work and wiring, just don't want to go on a hunting expedition through harnesses. If I can get something that will work with the wires I have great, if not, I guess I'll wire in a toggle switch or something to bypass the thermostat.

wnjj

Cornelius, Oregon

Senior Member

Joined: 01/11/2007

View Profile


Offline
Posted: 07/15/21 08:37pm Link  |  Quote  |  Print  |  Notify Moderator

Pretty much any 12V thermostat will work. The wire colors usually follow a standard:

Red = +12v
Blue = gnd
Green = high fan
Yellow = cool (compressor)
White = heat

If you have any doubt you can find the wires on the AC unit to confirm.

Reply to Topic  |  Subscribe  |  Print Topic  |  Post New Topic  | 

Open Roads Forum  >  Tech Issues

 > Thermostat woes
Search:   Advanced Search

Search only in Tech Issues


New posts No new posts
Closed, new posts Closed, no new posts
Moved, new posts Moved, no new posts

Adjust text size:




© 2021 CWI, Inc. © 2021 Good Sam Enterprises, LLC. All Rights Reserved.