Good Sam Club Open Roads Forum: Class A Motorhomes: Alison transmission computer
Open Roads Forum Already a member? Login here.   If not, Register Today!  |  Help

Newest  |  Active  |  Popular  |  RVing FAQ Forum Rules  |  Forum Posting Help and Support  |  Contact  

Search:   Advanced Search

Search only in Class A Motorhomes

Open Roads Forum  >  Class A Motorhomes  >  Maintenance Issues & Tips

 > Alison transmission computer

Reply to Topic  |  Subscribe  |  Print Topic  |  Post New Topic  | 
Tom/Barb

Oak Harbor, Wa

Senior Member

Joined: 10/16/2009

View Profile



Good Sam RV Club Member


Posted: 08/02/21 09:45am Link  |  Quote  |  Print  |  Notify Moderator

Most probable cause ?
no shift panel lights,
no start.
ACC side of the ignition works, all systems work.
IGN side of the ignition works normal.
Strat position goes dead when you try to start.

Thanks for the help.


2000 Newmar mountain aire 4081 DP, ISC/350 Allison 6 speed, Wrangler JL toad.

Mel Stuplich

Wausau, WI

New Member

Joined: 03/21/2017

View Profile


Offline
Posted: 08/02/21 11:01am Link  |  Quote  |  Print  |  Notify Moderator

Tom/Barb
No 12V power to the Allison VIM ... (blown fuse?/ bad wire?)

Tom/Barb

Oak Harbor, Wa

Senior Member

Joined: 10/16/2009

View Profile



Good Sam RV Club Member


Posted: 08/02/21 12:20pm Link  |  Quote  |  Print  |  Notify Moderator

Mel Stuplich wrote:

Tom/Barb
No 12V power to the Allison VIM ... (blown fuse?/ bad wire?)


VIM. = ?

all fuses have been checked
all relays have been checked

all system operating.

except the start position.

the starter/relay/ ignition switch/ have been changed.

nothing fixed it.

larry cad

ohio

Senior Member

Joined: 05/23/2004

View Profile





Offline
Posted: 08/02/21 02:05pm Link  |  Quote  |  Print  |  Notify Moderator

Shift panel lights went out on mine, lost power to the panel. Apparently broken wire. Shop installed a new wire. All good.


Today is my personal best for most consecutive days alive.

Our Travel Blog

donkeydew

OR

Senior Member

Joined: 12/14/2009

View Profile



Good Sam RV Club Member

Offline
Posted: 08/02/21 07:29pm Link  |  Quote  |  Print  |  Notify Moderator

it can be many things when my cat low fuel pressure sensor when out it went blank
mobile mechanic scanned the engine and replaced the sensor all was good the allison pad lit right back up. i had called coach net and the first thing they ask was if the pad was lit,when i said no the ask if i needed a tow or or mobile mech.

kane8907

East Brunswick,NJ

New Member

Joined: 09/23/2020

View Profile


Offline
Posted: 08/09/21 05:23am Link  |  Quote  |  Print  |  Notify Moderator

How much does it cost to change an pressure sensor in a repair shop?

**Link Removed**

* This post was edited 08/10/21 02:05pm by an administrator/moderator *

ArchHoagland

Clovis, CA, USA

Senior Member

Joined: 11/28/2004

View Profile



Good Sam RV Club Member

Offline
Posted: 08/10/21 03:22pm Link  |  Quote  |  Print  |  Notify Moderator

Any luck yet? Besides bad luck....


2004 Monaco La Palma 36DBD
Workhorse W22 8.1 Gas Allison 1000, 7.1 mpg

2000 LEXUS RX300 FWD 22MPG 4020 LBS
US Gear Brakes


gatorcq

Arizona

Senior Member

Joined: 03/15/2004

View Profile





Offline
Posted: 08/13/21 05:57am Link  |  Quote  |  Print  |  Notify Moderator

A friend went through this. Bad ground on/near the TCM.


Dale & Susan
DaGirls II Rv - Dakota & Tilly Traveling Companions.
2008 Alfa Gold, 2015 Ford F150 XLT
Roadmaster and Air Brake System
1600 Watts, Magnum Inv/Chg&Solar
800 Lithium Battery
DaGirslRV Blog

Tom/Barb

Oak Harbor, Wa

Senior Member

Joined: 10/16/2009

View Profile



Good Sam RV Club Member


Posted: 08/17/21 09:53pm Link  |  Quote  |  Print  |  Notify Moderator

We have discovered the problem,, we changed the Transmission ECU,, it did not fix the problem,,changing the major Battery cable fixed it.

corrosion ate the end of the cable nearly off. it will show continuity, but when place a load the cable would fail.

ArchHoagland

Clovis, CA, USA

Senior Member

Joined: 11/28/2004

View Profile



Good Sam RV Club Member

Offline
Posted: 08/18/21 06:29pm Link  |  Quote  |  Print  |  Notify Moderator

Thanks for the update, glad to hear it's fixed and I'll bet you are too...

Reply to Topic  |  Subscribe  |  Print Topic  |  Post New Topic  | 

Open Roads Forum  >  Class A Motorhomes  >  Maintenance Issues & Tips

 > Alison transmission computer
Search:   Advanced Search

Search only in Class A Motorhomes


New posts No new posts
Closed, new posts Closed, no new posts
Moved, new posts Moved, no new posts

Adjust text size:




© 2021 CWI, Inc. © 2021 Good Sam Enterprises, LLC. All Rights Reserved.