Good Sam Club Open Roads Forum: Tech Issues: LP Generator Starts then Stalls
Open Roads Forum Already a member? Login here.   If not, Register Today!  |  Help

Newest  |  Active  |  Popular  |  RVing FAQ Forum Rules  |  Forum Posting Help and Support  |  Contact  

Search:   Advanced Search

Search only in Tech Issues

Open Roads Forum  >  Tech Issues

 > LP Generator Starts then Stalls

Reply to Topic  |  Subscribe  |  Print Topic  |  Post New Topic  | 
ghmuller

New Jersey

New Member

Joined: 02/11/2022

View Profile


Offline
Posted: 02/11/22 01:16pm Link  |  Quote  |  Print  |  Notify Moderator

I have an ONAN 5500 LP Generator. My 5th Wheel has 3 40 lb bottles. Two on a two-stage auto-changeover regulator, and one on it's own regulator.
The main lines from each regulator are connected via a T. The hose for the generator is connected to a T located at the output of the single-tank regulator. The gnerator has always worked fine. Recently Jayco did a recall to replace a potentially bad regualtor. They replace the auto-changeover regulator with a Camco model.

I recently went on a trip and tried to use the generator. The single tank is shut off, and the dual tanks are on. The generator starts, and then stalls in 3 seconds. Sounds fuel starved. I opened the single tank and the generator will start and run fine. I can run with only the single tank on, and the generator, 40,000 btu furnace and stove all run at the same time. If I turn on the dual tanks and shut off the single, the generator stalls and the furnace goes out. 30 seconds later the furnace re-ignites and runs okay. It seesms as though the new regulator can't supply the amount of LP that the generator demands. Has anyone experience this kind of problem? Any ideas of what I can check? (When they replaced the regulator they did a leak-down test but did not do a demand test).

Thanks!

CA Traveler

The Western States

Senior Member

Joined: 01/03/2004

View Profile


Offline
Posted: 02/11/22 01:50pm Link  |  Quote  |  Print  |  Notify Moderator

I'll guess that the new regulator is either defective or inadequate for the additional gen propane requirement. Did Jacoy supply 3 tanks, T etc. or has there been modifications?


2009 Holiday Rambler 42' Scepter with ISL 400 Cummins
750 Watts Solar Morningstar MPPT 60 Controller
2014 Grand Cherokee Overland

Bob


Grit dog

Black Diamond, WA

Senior Member

Joined: 05/06/2013

View Profile


Offline
Posted: 02/11/22 01:52pm Link  |  Quote  |  Print  |  Notify Moderator

Sounds like you diagnosed the problem 100%.
It also appears that the dealer replaced the old one.
Is there a reason not to call them and tell them, the new regulator they installed doesn't work right, and get it replaced again?


2016 Ram 2500, MotorOps.ca EFIlive tuned, 5” turbo back, 6" lift on 37s
2017 Heartland Torque T29 - Sold.
Couple of Arctic Fox TCs - Sold

wolfe10

Texas

Senior Member

Joined: 10/08/2000

View Profile


Offline
Posted: 02/11/22 01:55pm Link  |  Quote  |  Print  |  Notify Moderator

Wonder if the two tied tanks have an excess flow prevented?? If so, turn off both tanks and VERY slowly open the valves.


Brett Wolfe
Ex: 2003 Alpine 38'FDDS
Ex: 1997 Safari 35'
Ex: 1993 Foretravel U240

Diesel RV Club:http://www.dieselrvclub.org/

ghmuller

New Jersey

New Member

Joined: 02/11/2022

View Profile


Offline
Posted: 02/11/22 03:25pm Link  |  Quote  |  Print  |  Notify Moderator

CA Traveler wrote:

I'll guess that the new regulator is either defective or inadequate for the additional gen propane requirement. Did Jacoy supply 3 tanks, T etc. or has there been modifications?


Yes the RV came with the three tanks. No mods.

ghmuller

New Jersey

New Member

Joined: 02/11/2022

View Profile


Offline
Posted: 02/11/22 03:26pm Link  |  Quote  |  Print  |  Notify Moderator

wolfe10 wrote:

Wonder if the two tied tanks have an excess flow prevented?? If so, turn off both tanks and VERY slowly open the valves.


They can run the furnace and stove, but I’ll try this.

dpglifestyle

michigan

New Member

Joined: 06/18/2017

View Profile


Offline
Posted: 02/12/22 03:53am Link  |  Quote  |  Print  |  Notify Moderator

Had the same issue when I replaced my regulator. New regulator was said to be capable of supplying up to 400,000BTU but generator error codes said fuel issue. Returned Camco regulator and replaced with different brand and problem solved. Sounds like the regulator on your single tank has the ability to supply enough volume.


2015 Lifestyle LS36FW
2016 GMC 3500 CC Dually

John&Joey

Summer-North,Winter-South

Senior Member

Joined: 05/20/2007

View Profile



Good Sam RV Club Member


Posted: 02/12/22 08:15pm Link  |  Quote  |  Print  |  Notify Moderator

Check the air filter.

Reply to Topic  |  Subscribe  |  Print Topic  |  Post New Topic  | 

Open Roads Forum  >  Tech Issues

 > LP Generator Starts then Stalls
Search:   Advanced Search

Search only in Tech Issues


New posts No new posts
Closed, new posts Closed, no new posts
Moved, new posts Moved, no new posts

Adjust text size:




© 2023 CWI, Inc. © 2023 Good Sam Enterprises, LLC. All Rights Reserved.