Good Sam Club Open Roads Forum: Tech Issues: Dometic Mother Board
Open Roads Forum Already a member? Login here.   If not, Register Today!  |  Help

Newest  |  Active  |  Popular  |  RVing FAQ Forum Rules  |  Forum Posting Help and Support  |  Contact  

Search:   Advanced Search

Search only in Tech Issues

Open Roads Forum  >  Tech Issues

 > Dometic Mother Board

Reply to Topic  |  Subscribe  |  Print Topic  |  Post New Topic  | 
Page of 4  
Prev
PastorCharlie

NC

Senior Member

Joined: 03/28/2004

View Profile





Offline
Posted: 05/20/22 03:31pm Link  |  Quote  |  Print  |  Notify Moderator

dougrainer wrote:

6300 is the Low Profile Penguin model. THAT model will have the Board ON the AC unit. You have to remove the upper cover of the unit and then remove the Evaporator cover either Styrofoam or plastic, depending on the year of the Penguin. Once the evap cover is removed you will see a 2 by 4 inch metal electrical box in front of the evaporator. THAT houses the 120 from the inside breaker and connects to the 120 going to the Board on the AC unit. This is where you may have a burnt 120 connectiOn IF THE 120 AT THE MAIN BREAKER PANEL SHOWS 120 OUTPUT FROM THE INTELLITEC EMS MODULE. Since you have to go on top and your age, you may have to get either a professional or somebody that is very handy to do the roof top checks. Regardless, you NEED someone that can operate a multitester to check various 120 volt circuits if you are not handy to use one. Doug


Doug, I am parked on the campus of an university and got a chance to have their Heating and Cooling tech look at my problem. There is no 120 present on the output from Intellitec EMS Module. He by-passed the EMS with the 120 and the rear air conditioner powered up and runs great. He did not have the time or proper testing equipment with him to check more. I am able to turn the rear unit on and off by flipping the breaker to allow it to help with the front unit when needed until I can get more info and service. It appears the problem is with the Intellitec EMS or tstat.

Thanks for your help.

PastorCharlie

NC

Senior Member

Joined: 03/28/2004

View Profile





Offline
Posted: 05/30/22 08:32pm Link  |  Quote  |  Print  |  Notify Moderator

Update: The tstat is cycling the rear AC on and off as needed. Tstat ok. Motherboard ok. AC ok. Bad EMS.

Reply to Topic  |  Subscribe  |  Print Topic  |  Post New Topic  | 
Page of 4  
Prev

Open Roads Forum  >  Tech Issues

 > Dometic Mother Board
Search:   Advanced Search

Search only in Tech Issues


New posts No new posts
Closed, new posts Closed, no new posts
Moved, new posts Moved, no new posts

Adjust text size:




© 2022 CWI, Inc. © 2022 Good Sam Enterprises, LLC. All Rights Reserved.