Good Sam Club Open Roads Forum: Tech Issues: GENERAC GENERATOR ISSUE
Open Roads Forum Already a member? Login here.   If not, Register Today!  |  Help

Newest  |  Active  |  Popular  |  RVing FAQ Forum Rules  |  Forum Posting Help and Support  |  Contact  

Search:   Advanced Search

Search only in Tech Issues

Open Roads Forum  >  Tech Issues

 > GENERAC GENERATOR ISSUE

Reply to Topic  |  Subscribe  |  Print Topic  |  Post New Topic  | 
Page of 3  
Prev  |  Next
garym114

Bluff Dale, Texas

Senior Member

Joined: 07/24/2006

View Profile


Offline
Posted: 06/07/22 12:12pm Link  |  Quote  |  Print  |  Notify Moderator

The pump runs when the gen is running. Prim just gets gas to the carb for it to start.


2000 Sea Breeze F53 V10 - CR-V Toad
Some RV batteries live a long and useful life, some are murdered.
Get a Digital Multimeter and Learn How to Use It


Grit dog

Black Diamond, WA

Senior Member

Joined: 05/06/2013

View Profile


Offline
Posted: 06/07/22 02:28pm Link  |  Quote  |  Print  |  Notify Moderator

SeligL wrote:

Another question if I can’t solve this problem, is it harmful to leave Prime on as gennie runs and works fine when Prime is on or pressed for 3secs every 1-2 minutes.


Prime should be a momentary switch, for obvious reasons.
If it stays on, you have the risk of the fuel pump running deadhead or leaking fuel or blowing out or blowing up your vehicle….if you ever forget to turn it off.


2016 Ram 2500, MotorOps.ca EFIlive tuned, 5” turbo back, 6" lift on 37s
2017 Heartland Torque T29

bounder39zman

SC

Full Member

Joined: 03/19/2014

View Profile



Good Sam RV Club Member

Offline
Posted: 06/08/22 10:48am Link  |  Quote  |  Print  |  Notify Moderator

The prime switch used on this Generac gen. has both NC(normally closed), and NO (normally open) contacts in the switch. in prime mode, the 12v on wire 15 is connected to fuel pump thru NO contacts. In run mode, 12v from control board connects to fuel pump thru switch NC contacts. Sounds like you just need to install correct switch, Generac part# 092113

SeligL

BELLEVUE, WA

New Member

Joined: 06/05/2022

View Profile


Offline
Posted: 06/08/22 11:25am Link  |  Quote  |  Print  |  Notify Moderator

Thanks bounder39zman. I have ordered a new Prime switch. What you write makes sense. I don’t think I mentioned that I replaced the cracked Prime switch with one I had as a spare at home. Didn’t really think it would be critical but maybe it is. So I’ll wait for new switch and see then. On my diagram there are wires 15 to fuse, 14A (RED) to Fuel Pump shutoff valve and 14 to terminal connector. (15 does not go to FP). When I connect new switch it looks like 14A goes to middle prong., bottom one? To fuse and therefore top prong to terminal connector. Please correct me as I don’t want to wire this incorrectly.
Many thanks.

Grit dog

Black Diamond, WA

Senior Member

Joined: 05/06/2013

View Profile


Offline
Posted: 06/08/22 11:27am Link  |  Quote  |  Print  |  Notify Moderator

SeligL wrote:

Another question if I can’t solve this problem, is it harmful to leave Prime on as gennie runs and works fine when Prime is on or pressed for 3secs every 1-2 minutes.

Edit, you replied while I was typing. Good to see yo're fixing it right.
Cant help with the pin outs on the switch, sorry

SeligL

BELLEVUE, WA

New Member

Joined: 06/05/2022

View Profile


Offline
Posted: 06/08/22 04:59pm Link  |  Quote  |  Print  |  Notify Moderator

While I wait for new Fuel Prime Switch to arrive, looking at old cracked one I see 1a and 1b at each end prong and 1 in middle,
So I assume correct connection will be 14A (RED) to middle prong (1).
15 goes to fuse and 14 to Terminal Connector. Can anyone tell me if 15 or 14 goes to prong 1a (and other one will go to 1b).
Thanks

bounder39zman

SC

Full Member

Joined: 03/19/2014

View Profile



Good Sam RV Club Member

Offline
Posted: 06/14/22 03:45pm Link  |  Quote  |  Print  |  Notify Moderator

Your wiring is correct. 14A to middle terminal (goes to F.P.)
14 goes to top terminal (from terminal on RUN B+ connector, has power from control board when running. wire 15 goes on bottom terminal, has batt 12V+ from fuse. when you push switch to prime, batt 12V+ is connected thru switch to fuel pump. When genset is running, 12V+ is connected to fuel pump (14A) from wire 14

SeligL

BELLEVUE, WA

New Member

Joined: 06/05/2022

View Profile


Offline
Posted: 06/14/22 06:22pm Link  |  Quote  |  Print  |  Notify Moderator

Thanks bounder39zman.

Switch is due to arrive today.

Will hopefully connect wires correctly.

SeligL

BELLEVUE, WA

New Member

Joined: 06/05/2022

View Profile


Offline
Posted: 06/18/22 05:14pm Link  |  Quote  |  Print  |  Notify Moderator

Finally received the new prime switch (Generac G092113 Switch from AP Electric & Generators) and wired it as bounder39zman indicated (and so clearly explained how it works).

It works fine now!!

I guess the "ordinary switch" I naively used to replace the cracked one cut off the few pump when in Run mode. This explains why it would run for only 1-2 minutes unless I kept on priming it.

So a BIG THANK YOU to you all for your help, especially bounder39zman

bounder39zman

SC

Full Member

Joined: 03/19/2014

View Profile



Good Sam RV Club Member

Offline
Posted: 06/19/22 06:52pm Link  |  Quote  |  Print  |  Notify Moderator

Glad I could be of help. (I actually do this sort of thing for a living ...generator tech for 35+ years)

Reply to Topic  |  Subscribe  |  Print Topic  |  Post New Topic  | 
Page of 3  
Prev  |  Next

Open Roads Forum  >  Tech Issues

 > GENERAC GENERATOR ISSUE
Search:   Advanced Search

Search only in Tech Issues


New posts No new posts
Closed, new posts Closed, no new posts
Moved, new posts Moved, no new posts

Adjust text size:




© 2022 CWI, Inc. © 2022 Good Sam Enterprises, LLC. All Rights Reserved.