Good Sam Club Open Roads Forum: Class A Motorhomes: Onan Running Problems
Open Roads Forum Already a member? Login here.   If not, Register Today!  |  Help

Newest  |  Active  |  Popular  |  RVing FAQ Forum Rules  |  Forum Posting Help and Support  |  Contact  

Search:   Advanced Search

Search only in Class A Motorhomes

Open Roads Forum  >  Class A Motorhomes  >  All

 > Onan Running Problems

Reply to Topic  |  Subscribe  |  Print Topic  |  Post New Topic  | 
Page of 2  
Next
haste maker

alabama

Senior Member

Joined: 05/29/2009

View Profile



Good Sam RV Club Member

Offline
Posted: 07/07/22 11:48am Link  |  Quote  |  Print  |  Notify Moderator

I have a 2007 32BA Allergo with a 7000 watt Onan gas generator, the generator ran yesterday for 10 hours then quit, when I tried to restart it was very difficult to restart, after I did get it started again it ran for 10 minutes, and quit again, it was difficult to restart this time also, but did start only to run for 2 minutes...I didn't try to restart again. The red light on the dash switch was flashing off & on, each time the generator quit...It does have plenty of gas RV tank is full, all filters were changed 2 weeks ago, and it has been running great until now.

Anyone have any ideas of where I need to start looking to repair the generator?

* This post was edited 07/07/22 12:14pm by haste maker *


Retried Teamster
2007 Allergo

ken1961

Florida

Full Member

Joined: 02/13/2006

View Profile



Good Sam RV Club Member

Offline
Posted: 07/07/22 12:16pm Link  |  Quote  |  Print  |  Notify Moderator

https://generatorsage.com/why-onan-generator-starts-then-shuts-down/


Ken

older_fossil

USA (fulltiming)

Senior Member

Joined: 12/15/2001

View Profile


Offline
Posted: 07/07/22 02:12pm Link  |  Quote  |  Print  |  Notify Moderator

If the light on the dash start switch is blinking in a repeating pattern, this is very likely an error code. The Onan 4000 in our previous Class C would blink an error code on the start/stop switch on the generator. First thing I would do is check the oil level. I had a problem with our gas Onan stopping after running a while that turned out to be a bad fuel filter.

Art


Art & Barbara
2016 Tiffin AB 37AP
2011 Jeep Grand Cherokee

haste maker

alabama

Senior Member

Joined: 05/29/2009

View Profile



Good Sam RV Club Member

Offline
Posted: 07/07/22 02:34pm Link  |  Quote  |  Print  |  Notify Moderator

ken1961 wrote:

https://generatorsage.com/why-onan-generator-starts-then-shuts-down/

Thanks I will try this...I did fill it to the top mark on the drip stick & it was close to the low mark before the filters were changed.

PhilipB

MO

Senior Member

Joined: 01/30/2004

View Profile



Good Sam RV Club Member


Posted: 07/07/22 03:50pm Link  |  Quote  |  Print  |  Notify Moderator

My 5500 on toy hauler in signature was boiling the fuel, then shutting down. We made a shroud to channel the exhaust side away from the air intake side. The symptoms made is appear to be a clogged carb/fuel filter or bad fuel pump.


2015 Ram 2500
2013 Raptor 310TS

midnightsadie

ohio

Senior Member

Joined: 01/07/2008

View Profile


Offline
Posted: 07/08/22 05:41am Link  |  Quote  |  Print  |  Notify Moderator

fuel line colapesed fuel line. try a different fuel source clean plug.

allbrandauto

maryland

Senior Member

Joined: 09/19/2013

View Profile



Good Sam RV Club Member

Offline
Posted: 07/08/22 07:39am Link  |  Quote  |  Print  |  Notify Moderator

fuel pump fuel pump fuel pump

Rickyrocket

Coventry,RI

Senior Member

Joined: 04/09/2007

View Profile



Good Sam RV Club Member

Offline
Posted: 07/09/22 01:43pm Link  |  Quote  |  Print  |  Notify Moderator

If indeed the fuel pump pull it and look for a part number,Google the part number fuel pump,do not list Onan,most likely it will be a pump for a riding lawnmower costing $25 or so not the $300 for the Onan part.

FloridaRosebud

Melbourne

Senior Member

Joined: 05/27/2018

View Profile


Offline
Posted: 07/10/22 01:23pm Link  |  Quote  |  Print  |  Notify Moderator

Rickyrocket wrote:

If indeed the fuel pump pull it and look for a part number,Google the part number fuel pump,do not list Onan,most likely it will be a pump for a riding lawnmower costing $25 or so not the $300 for the Onan part.


I tried that and bought an aftermarket pump for my 5500. It would not fit. Bolt holes would not line up, and there was no way to mod it to make it work. Bought the Onan and fit like it was supposed to.....buyer beware.....

Al

haste maker

alabama

Senior Member

Joined: 05/29/2009

View Profile



Good Sam RV Club Member

Offline
Posted: 07/10/22 03:25pm Link  |  Quote  |  Print  |  Notify Moderator

Update according to the code on my unit "47" the problem is "Ignition Fault"...so I will taking it to an Onan repair shop...thanks for all the info..

Reply to Topic  |  Subscribe  |  Print Topic  |  Post New Topic  | 
Page of 2  
Next

Open Roads Forum  >  Class A Motorhomes  >  All

 > Onan Running Problems
Search:   Advanced Search

Search only in Class A Motorhomes


New posts No new posts
Closed, new posts Closed, no new posts
Moved, new posts Moved, no new posts

Adjust text size:




© 2022 CWI, Inc. © 2022 Good Sam Enterprises, LLC. All Rights Reserved.